Make WordPress Core

Opened 4 years ago

Closed 12 months ago

Last modified 12 months ago

#19680 closed defect (bug) (duplicate)

Navmenu incorrectly removing items

Reported by: camiloclc Owned by:
Milestone: Priority: normal
Severity: major Version: 3.3
Component: Menus Keywords: needs-patch
Focuses: Cc:


One of my menus is filled with categories. If I create a tag with the same name as a category and then remove this tag, the menu item for the category is also removed.

1 - create a category called "Example" (optionally associate some posts with it)
2 - add category to a navmenu
3 - create a tag called "Example" (optionally associate some posts with it)
4 - remove tag

Now the category "Example" is no longer in the navmenu it was added to.

Change History (5)

comment:1 @nofearinc4 years ago

Same here, probably nav menu is using slugs which could lead to a conflict when using different taxonomies with the same slug same slug

comment:2 @nofearinc4 years ago

Small observation (core guys would say if it is related or not).

In taxonomy.php term_id is used and in wp_term_taxonomy both categories and tags using same name are linked to the same term_id.

Edit: using t.name comparison here

Last edited 4 years ago by nofearinc (previous) (diff)

comment:3 @SergeyBiryukov4 years ago

Sounds like a duplicate of #5809.

comment:4 @chriscct712 months ago

  • Keywords needs-patch added; navmenu removed
  • Resolution set to duplicate
  • Status changed from new to closed

Definitely a duplicate of #5809

comment:5 @DrewAPicture12 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.