WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#19683 closed defect (bug) (duplicate)

image returned instead of page text when using permalinks - reproducable

Reported by: juggledad Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3
Component: Media Keywords:
Focuses: Cc:

Description

If there is an image with the same name as a page title and permalinks are anything but the default, the image will show instead of the page text. This is reproducable and the same issue could not be recreated in 3.2.1

Steps used to verify the 'bug' - this was done on a fresh install of 3.3
1) log in as admin
2) go to dashboard->media->add new add an image call it 'imagebug.jpg' (the name is not important)
3) add a new page - set the title to 'imagebug' and fill in the text with what ever text you want
4) go view the page, you will see the title and the text
5) change the permalinks to something other than the default
6) go view the page again - you will see the image instead of the page text

now for something interesting
1) go to the media library and edit the image
2) change teh TITLE to 'foo' and hit save
3) change the TITLE back to 'imagebug' and save it
4) go view the page
now the page text will show no matter what the permalinks is set to.

Change History (4)

comment:1 juggledad2 years ago

p.s. it didn't matter if the image was uploaded with the 'drag and drop' or the 'browser upload' method.

comment:2 SergeyBiryukov2 years ago

Sounds like a duplicate of #16438 and #15665.

comment:3 scribu2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

comment:4 juggledad2 years ago

Sorry, I did not encounter those tickets when searching (wrong keywords...sigh)
I just confirmed that the patch in 16438.diff (Ticket #16438) does correct this issue.

Note: See TracTickets for help on using tickets.