Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#19687 closed defect (bug) (fixed)

Third column of welcome panel wraps to a new row

Reported by: pavelevap Owned by: nacin
Milestone: 3.5 Priority: normal
Severity: normal Version: 3.3
Component: Administration Keywords: has-patch commit
Focuses: Cc:

Description (last modified by helenyhou)

I encountered some problems in older Internet Explorer versions:

1) There is missing "Browse" button when you try to upload new media (using Browser uploader). IE7/8, see attached screenshot.

2) Third column in Welcome panel is moved to another row in IE7, see attached screenshot.

Attachments (13)

Missing_Browse_button.png (8.0 KB) - added by pavelevap 4 years ago.
Third_welcome_column.png (29.7 KB) - added by pavelevap 4 years ago.
19687.add-new-media.png (21.3 KB) - added by SergeyBiryukov 4 years ago.
ie7_new_welcome.jpg (152.5 KB) - added by ocean90 3 years ago.
19687.diff (1.0 KB) - added by lessbloat 3 years ago.
19687.2.diff (1.0 KB) - added by JustinSainton 3 years ago.
Refresh of @lessbloat's original patch
19687.r22680.png (70.5 KB) - added by SergeyBiryukov 3 years ago.
19687.r22680-rtl.png (71.4 KB) - added by SergeyBiryukov 3 years ago.
19687.3.diff (1.1 KB) - added by SergeyBiryukov 3 years ago.
19687.3.after-ie7.png (63.1 KB) - added by SergeyBiryukov 3 years ago.
19687.3.after-ie7-rtl.png (63.4 KB) - added by SergeyBiryukov 3 years ago.
19687.3.after-ie8.png (67.0 KB) - added by SergeyBiryukov 3 years ago.
19687.3.after-ie8-rtl.png (65.7 KB) - added by SergeyBiryukov 3 years ago.

Download all attachments as: .zip

Change History (34)

comment:1 @Ipstenu4 years ago

  • Keywords close added

IE 7 and IE 8 aren't fully supported. They're going to have problems (which is why you get an alert box telling you that the browser is old in the main admin screen). I suspect this is a wontfix if it's not present in IE 9.

comment:2 @pavelevap4 years ago

OK, I agree with second point, but IE8 is supported now and it is not possible to upload media using Browser uploader which can be real problem for some users...

comment:3 @ryanmurphy4 years ago

Could not reproduce either issue using IE8 and r19633

comment:4 @ocean904 years ago

  • Keywords close removed

comment:5 @solarissmoke4 years ago

  • Keywords close added

I can't reproduce either, in IE7 or 8. Using r19732.

@pavelevap, are you using something like IETester? Because if you are, then it has issues rendering input type="file" tags which are not present in real IE7/8 browsers.

comment:6 @SergeyBiryukov4 years ago

I can reproduce the second issue in "real" IE 7. Would like to see if we can fix this without much hacking.

comment:7 @SergeyBiryukov4 years ago

As for the first issue, here's what I see in IE 7/8: 19687.add-new-media.png.

comment:8 @Ipstenu4 years ago

It works fine for me on Win XP and IE 8.

comment:9 @pavelevap4 years ago

solarissmoke: My friend originally showed it to me, I am not sure if it was exactly IETester, but probably it was any tool. I can not reproduce this missing button on my VirtualPC now. I also tried IETester and button is really missing here, interesting... Thank you very much for this hint! So first point is probably invalid.

comment:10 @SergeyBiryukov4 years ago

  • Component changed from General to UI

Since the second issue only seems to appear in IE 7, which is going to be deprecated (#18199), not sure if it's actually worth fixing. IE 8 shows Welcome panel properly.

comment:11 @helenyhou3 years ago

  • Component changed from UI to Help/About
  • Description modified (diff)
  • Summary changed from Some IE7/8 glitches to Third column of welcome panel wraps to a new row

@ocean903 years ago

@lessbloat3 years ago

comment:12 @lessbloat3 years ago

  • Cc pavelevap@… removed
  • Component changed from Help/About to Administration
  • Keywords has-patch needs-testing added; close removed
  • Milestone changed from Awaiting Review to 3.5

19687.diff​ should set the welcome screen straight in IE7 & IE8.

comment:13 @lessbloat3 years ago

  • Cc pavelevap added

Sorry didn't mean to remove pavelevap@.

comment:14 @nacin3 years ago

  • Keywords commit needs-refresh added; needs-testing removed

Patch no longer applies cleanly.

@JustinSainton3 years ago

Refresh of @lessbloat's original patch

comment:15 @JustinSainton3 years ago

  • Keywords needs-refresh removed

comment:16 @nacin3 years ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In 22680:

IE sanity for the welcome panel. props lessbloat, JustinSainton. fixes #19687.

@SergeyBiryukov3 years ago

@SergeyBiryukov3 years ago

comment:17 @SergeyBiryukov3 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

[22680] added back margin: 0 -25px 0 4%, which was removed in [22638] and is no longer relevant.

19687.3.diff is another take. Tested in IE 7, IE 8, Firefox 16, with 800x600, 1024x768, and 1440x900 window sizes.

Screenshots: 19687.3.after-ie7.png, 19687.3.after-ie7-rtl.png, 19687.3.after-ie8.png, 19687.3.after-ie8-rtl.png.

comment:18 @lessbloat3 years ago

+1 to 19687.3.diff. Looks good.

comment:19 @nacin3 years ago

In 22696:

Welcome panel IE fixes. props SergeyBiryukov, see #19687.

comment:20 @nacin3 years ago

Anything else? RTL?

comment:21 @SergeyBiryukov3 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.