WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#19697 closed defect (bug) (fixed)

Wrong links in Welcome panel

Reported by: pavelevap Owned by:
Milestone: 3.5 Priority: normal
Severity: normal Version: 3.3
Component: Help/About Keywords: has-patch
Focuses: Cc:

Description

It is probably caused by non-existing sample post and sample page. First admin usually delete automatically generated content, but every other user will see text "View the sample page and post" with links leading to /wp-admin/, that means back to Dashboard. Strange...

Second small problem: "Write your first post" link leads to post-new.php, but "Create an About Me page" leads to list of pages (and not page-new.php which could be expected).

Attachments (2)

welcome.diff (1.0 KB) - added by tw2113 4 years ago.
Changed destination of "Create an About Me" link in the initial welcome display, and had it auto-add "About Me" as a title
welcome1.diff (1.0 KB) - added by tw2113 4 years ago.
no "About Me" auto-created title

Download all attachments as: .zip

Change History (12)

comment:1 follow-up: @jane4 years ago

The welcome box on the dashboard is only supposed to be shown to the originating admin user, no one else. This was specifically so that we wouldn't have to worry about who had what permissions etc.

@tw21134 years ago

Changed destination of "Create an About Me" link in the initial welcome display, and had it auto-add "About Me" as a title

comment:2 @tw21134 years ago

  • Keywords has-patch added

Basically just changes the Create an About Me link to the New Page editor, and added "About Me" to the title field via a GET variable

comment:3 @pavelevap4 years ago

jane: Thank you for clarifying! But maybe small check if sample content exist would avoid this small problem. Also originating admin can delete sample content and then checking Welcome panel with wrong links...

tw2113: Thank you for patch, but hardcoding "About me" is not a good idea, I guess (especially for translators).

I found also a third very minor glitch. Text "Make sure to click Save on each Settings screen" is probably meant for all links in first column, but there is also link to Profile where is button "Update Profile" and not "Save".

@tw21134 years ago

no "About Me" auto-created title

comment:4 in reply to: ↑ 1 ; follow-ups: @nacin4 years ago

Replying to jane:

The welcome box on the dashboard is only supposed to be shown to the originating admin user, no one else. This was specifically so that we wouldn't have to worry about who had what permissions etc.

The issue is if the welcome panel is shown again by an administrator. The solution would be to do an actual get_post(1) and get_post(2) and ensure they exist. We're already doing a get_permalink(1) and get_permalink(2) so there won't be additional queries. The string might need to be modified a bit.

"Create an About Me page", as far as I know, was designed to take the individual to the main Pages screen, after which they can click 'Add New'.

comment:5 in reply to: ↑ 4 @DrewAPicture4 years ago

Replying to pavelevap:

Second small problem: "Write your first post" link leads to post-new.php, but "Create an About Me page" leads to list of pages (and not page-new.php which could be expected).

Replying to nacin:

"Create an About Me page", as far as I know, was designed to take the individual to the main Pages screen, after which they can click 'Add New'.

I agree with the way it was originally written. There's a very subtle difference between 'Create' a page and 'Write' your first post. I believe it falls outside WP verbiage to 'Write' a page. We 'Write' posts and 'Create' pages. Along that vein, however, we should still point people to either the listings screens or the new post/page screens and be consistent about it.

Version 0, edited 4 years ago by DrewAPicture (next)

comment:6 @DrewAPicture4 years ago

  • Cc xoodrew@… added

comment:7 in reply to: ↑ 4 @SergeyBiryukov4 years ago

Replying to nacin:

"Create an About Me page", as far as I know, was designed to take the individual to the main Pages screen, after which they can click 'Add New'.

There was also an idea of a pointer aimed at the "Add New" button.

comment:8 @tw21134 years ago

  • Cc michael.d.beckwith@… added

comment:9 @MikeHansenMe3 years ago

  • Cc mdhansen@… added
  • Keywords close added

Currently on the welcome screen it has the following links
"Write your first blog post" that links to post-new.php
"Add an About page" links to post-new.php?post_type=page

both of these behave the same by creating new pages/posts and act as you would expect.
Proposing we close this ticket as it seems to be resolved.

comment:10 @SergeyBiryukov3 years ago

  • Component changed from General to Help/About
  • Keywords close removed
  • Milestone changed from Awaiting Review to 3.5
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.