WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#19720 closed defect (bug) (duplicate)

WP Importer does not work on 3.3

Reported by: memuller Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3
Component: Import Keywords: reporter-feedback
Focuses: Cc:

Description

As described by several users on forum post:

http://wordpress.org/support/topic/xml-to-wxr-issue?replies=12

The importing/exporting functions on WP 3.3 are not working; returning the following error on import:

This does not appear to be a WXR file, missing/invalid WXR version number

The problem is not present in previous versions, and rolling back the "importer" installation -> exporting/importing -> upgrading again is the only "solution" to the issue right now.

This is, of course, sub-optimal and (I believe) very serious, since it impairs the ability to move content around.

Change History (6)

comment:1 sheatsb2 years ago

  • Cc sheatsb added

comment:2 kurtpayne2 years ago

  • Cc kpayne@… added
  • Severity changed from major to normal

What version of WordPress created the WXR file you're having trouble importing?

Does the file contain a line like <wp:wxr_version>1.0</wp:wxr_version> ?

Does your installation of WordPress work with the theme unit test import file?

comment:3 SergeyBiryukov2 years ago

  • Keywords reporter-feedback added

comment:4 follow-up: memuller2 years ago

The file was created by a WP 3.3; and it does contain the line with the WXR version (which is 1.1).

I created clean installs of WP 3.1 and 3.2, and the export file of those installations also does not work (their WXR versions are 1.1, too). What does work is rolling back the installation on the "importer" side - it seems that the WP version that generates the file does not matter much.

So, as expected, the test import file also does not work.

comment:5 in reply to: ↑ 4 kurtpayne2 years ago

Replying to memuller:

What does work is rolling back the installation on the "importer" side - it seems that the WP version that generates the file does not matter much.

Are you reverting the WordPress core version from 3.3 to 3.2.1? Or are you changing the WordPress importer plugin version from 0.5 to an earlier version? If so which one?

So, as expected, the test import file also does not work.

Can you confirm the test import works in WordPress 3.2.1 and fails in WordPress 3.3 in an, otherwise, identical setup (same plugins, same theme, same vhost)?

Have you tried importing in 3.3 with all other plugins disabled?

The import code actually resides in the WordPress Importer Plugin so the core version shouldn't affect how it works.

comment:6 duck_2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

This should be fixed on the import side in 0.5.2. The plugin checks that the file exists before proceeding. See http://plugins.trac.wordpress.org/changeset/504381/wordpress-importer.

Closing as a duplicate of #19800 still to be fixed in WP core.

Note: See TracTickets for help on using tickets.