WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 14 months ago

Last modified 14 months ago

#19722 closed defect (bug) (duplicate)

Administering wih SSL and uploading images makes image links HTTPS

Reported by: ccolotti Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3
Component: Media Keywords:
Focuses: administration Cc:

Description

I am noticing this issue in 3.3 that all uploaded attachments are listed in the library using HTTPS in the location when administerng over SSL. I tried the patch.2 listed and it does not seem to change anything. Previously this was never an issue, but now all my images are getting added as HTTPS when I do not want them to be. I end up searching the DB for " https://" and replacing with HTTP after every post.

Will this ever get resolved back to normal so SSL admin can be used without having all attachments over SSL? I only have SSL for login and admin.

Change History (22)

comment:1 @ocean904 years ago

I tried the patch

Which?

comment:3 @ccolotti4 years ago

SOrry the one listed on this other bug:

http://core.trac.wordpress.org/ticket/15928#comment:14.

This seems to be a new issue with 3.3

Version 0, edited 4 years ago by ccolotti (next)

comment:4 @Ipstenu4 years ago

How are you uploading the images?

I've been uploading in the normal post editor for ages, using SSL for admin (and admin ONLY) since 3.2, and all my images remain http://blah

comment:5 @ccolotti4 years ago

Using the standard media uploader. Does it make a difference if they are multi-site? Is there an option I need to check? BTW - this is a NEW install. I spoke to someone else without the issue, but they have been upgrading all along. It smells like something is left after an upgrade, but not on a new install?

comment:6 @ccolotti4 years ago

The WP HTTPS plugin is also installed and network enabled. Maybe I can try disabling that. Not sure if it is even doing anything for the multi-sites.

comment:7 @ccolotti4 years ago

OKay I deleted the plugin and still whenever I add a media file the URL is HTTPS:// in the location and the file URL shown in the library. Definitely sounds upgrade vs new install possibly now.

Obviously if I remove force_SSL_Admin things upload and are set right.

Last edited 4 years ago by ccolotti (previous) (diff)

comment:8 @ipstenu4 years ago

For me, mine is an upgrade for sure (also multisite, but I tested on my 3.3 upgraded single site as well). So if you're not running any other plugins, that's looking likely. If you ARE, as always, turn 'em off first ;)

comment:9 @ccolotti4 years ago

Yeah no other HTTPS or SSL based plugins and this was all fine on 3.3 upgraded on another server. I move it all to a new one with a fresh install so something must be left in place on an upgrade from previous code.

comment:10 follow-up: @johnbillion4 years ago

  • Cc johnbillion@… added
  • Component changed from General to Administration
  • Severity changed from major to normal

I think I've seen this too on a multisite install, but I'm not sure under which circumstances.

comment:11 in reply to: ↑ 10 @ccolotti4 years ago

Replying to johnbillion:

I think I've seen this too on a multisite install, but I'm not sure under which circumstances.

I admit on my previous sites they were stand alone installs. I have just moved them all to a multi-site install for easier management. So maybe this is a multi-site specific issue.

comment:12 @SergeyBiryukov2 years ago

Closed #24220 as a duplicate.

comment:13 @ccolotti2 years ago

This is still an issue: You can have admin over SSL with a site over HTTP. In this situation, WordPress currently incorrectly inserts a images into your post content using the HTTPS scheme instead of HTTP. Is there a workaround and/or a fix that can be done for this? it's without reason doing this and all images are getting served up as HTTPS for no reason.

comment:14 @wonderboymusic2 years ago

@ccolotti - the fastest way to get this fixed is to upload a patch

comment:15 @ccolotti2 years ago

Has there ever been a patch? I would have though patches were rolled into updates to 3.5.1 by now.

comment:16 follow-ups: @wonderboymusic2 years ago

I see a lot a chatter from you on these tickets, but no patch - do you have a fix that you can put into a patch and upload?

comment:17 in reply to: ↑ 16 @ccolotti2 years ago

Replying to wonderboymusic:

I see a lot a chatter from you on these tickets, but no patch - do you have a fix that you can put into a patch and upload?

No I'm a user not a developer of any kind. I'm just trying to get help to get this issue resolved.

comment:18 in reply to: ↑ 16 @ccolotti2 years ago

Replying to wonderboymusic:

I see a lot a chatter from you on these tickets, but no patch - do you have a fix that you can put into a patch and upload?

I guess what I am looking for is someone who can develop a patch to do so since this is not an uncommon issue for anyone doing SSL administration on an HTTP based site.

comment:19 @lrissman22 months ago

I am running 3.6.1 and seem to have this same issue. It also exists using the plugin Eazyest Gallery which will automatically add items to "media" based on folder paths.

Was there ever a patch released?

comment:20 @nacin17 months ago

  • Component changed from Administration to Media
  • Focuses administration added

comment:21 @ericlewis14 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #15928.

comment:22 @DrewAPicture14 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.