WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 6 years ago

#19760 closed enhancement (fixed)

Allow localization of language names in multisite

Reported by: pavelevap Owned by: ocean90
Milestone: 4.0 Priority: normal
Severity: normal Version: 3.3.1
Component: I18N Keywords:
Focuses: Cc:

Description

There is Site Language settings in multisite (General Options). But all available languages are in English, so there is English, Czech, etc. But when I switch to Czech language, there is still only Czech and not "Čeština". I am not sure if there is need to translate all languages, but there should be localized at least selected language (or all available languages).

It is caused by function format_code_lang() in ms.php (line 463) where are all language names hardcoded in English.

Change History (7)

#1 @vanillalounge
8 years ago

This may warrant a separate ticket, but it seems that the list is hardcoded, with a set of locales which is partly out of date (example: no value for Brazilian Portuguese, pt_BR)

#4 @knutsp
7 years ago

  • Cc knut@… added

#5 @iandunn
6 years ago

  • Cc ian.dunn@… added

#6 @nacin
6 years ago

  • Milestone changed from Awaiting Review to 4.0

#7 @ocean90
6 years ago

  • Owner set to ocean90
  • Resolution set to fixed
  • Status changed from new to closed

In 29630:

Language packs: No WPLANG anymore.

  • The WPLANG constant is no longer needed. Remove define('WPLANG', ); from wp-config-sample.php. Populate WPLANG option based on the WPLANG constant. When get_option('WPLANG') is an empty string it will override WPLANG.
  • Introduce translations_api() which is available to communicate with the translation API. Move translation install related functions to a new file.
  • Replace mu_dropdown_languages() with wp_dropdown_languages(). wp_dropdown_languages() is now populated by the translation API.
  • Remove wp_install_load_language() and allow load_default_textdomain() to switch a core translation.

fixes #13069, #15677, #19760, #28730, #29281.

Note: See TracTickets for help on using tickets.