WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 4 months ago

#19770 closed feature request (maybelater)

Implement browser-side resizing with Plupload

Reported by: johnbillion Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3
Component: Upload Keywords: needs-patch
Focuses: Cc:

Description

#19174 removed the browser-side image resizing due to browser inconsistencies. We should fix it and reintroduce the feature.

A little related: #14459

Change History (12)

#1 @scribu
6 years ago

+1 altough I think it depends on Plupload itself to fix the inconsistencies, no?

#2 follow-up: @jayarjo
6 years ago

Hm... what are inconsistencies with Plupload?

#3 in reply to: ↑ 2 @SergeyBiryukov
6 years ago

Replying to jayarjo:

Hm... what are inconsistencies with Plupload?

See comment:ticket:19174:3.

#4 @jayarjo
6 years ago

  • Cc jayarjo added

Thanks for the link, although couldn't viably figure out what was expected behavior from Plupload's side..? I left a comment there but thread seems to be closed now. If we can come up with strict requirements for it, I could help to make it consistent.

Last edited 6 years ago by jayarjo (previous) (diff)

#5 follow-up: @fczuardi2
5 years ago

I don't mean to spam this bug, but since this was the page google pointed me when I was looking for how to enable back client-side image resize before uploading to wordpress, I think it can be useful to write the workaround / way to turn that feature back on again (WP 3.4.1) while it doesnt get properly reintroduced…

add_action( 'post-upload-ui', 'media_upload_max_image_resize' ); 

#6 @fczuardi2
5 years ago

  • Cc fczuardi2 added

#7 @DrewAPicture
5 years ago

  • Cc xoodrew@… added

Related #21407

#8 @tar.gz
5 years ago

  • Cc code@… added

#9 in reply to: ↑ 5 @DrewAPicture
5 years ago

Replying to fczuardi2:

I think it can be useful to write the workaround / way to turn that feature back on again (WP 3.4.1) while it doesnt get properly reintroduced…


add_action( 'post-upload-ui', 'media_upload_max_image_resize' ); 

FWIW, I've been adding the action back via a plugin since it was decided to remove it in #19174. I rewrote the language a bit but haven't had any reported problems. Uploading & resizing multiple photos works for us in FF14, Safari 6, Chrome 21, Opera 12 and IE9.

#10 @chriscct7
2 years ago

  • Keywords needs-patch added

This ticket was mentioned in Slack in #core-media by sergey. View the logs.


10 months ago

#12 @johnbillion
4 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to maybelater
  • Status changed from new to closed

Closing due to lack of traction

Note: See TracTickets for help on using tickets.