WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 18 months ago

#19775 closed defect (bug) (duplicate)

Plugin API requests should limit what data they request

Reported by: dd32 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Upgrade/Install Keywords: has-patch
Focuses: Cc:

Description

The Plugin API requests are returning data which isn't displayed/needed.

The data items in question for Plugin info is the full compatibility matrix (wp version, plugin version, does it work or not) and the Plugins tags.

This is easy to handle client or server side, simply requires extra array items to be added (in either case).

I'm leaning towards a core change here, as we don't currently have any decent documentation of the API, and as a result, bumping the API which is being used by others without a proper documentation and changing the return data ever so slightly doesn't seem worth it.

Attachments (3)

19775.diff (706 bytes) - added by dd32 2 years ago.
19775.2.diff (658 bytes) - added by DrewAPicture 2 years ago.
Better spacing and $args array
19775.2.2.diff (658 bytes) - added by DrewAPicture 2 years ago.

Download all attachments as: .zip

Change History (9)

dd322 years ago

comment:1 dd322 years ago

I also notice that the Contributors list is in there, but perhaps we should be displaying that on the plugin info screen as well as the primary author account?

Version 0, edited 2 years ago by dd32 (next)

comment:2 scribu2 years ago

That's some wacky indentation...

+1 for displaying the contributors as well as the main author.

comment:3 dd322 years ago

That's some wacky indentation...

Trac does Tabs as 8 spaces.. always looks wacky when it's been written with 4space = 1tab in mind as most code editors do. That can be split into a seperate $args array to limit the indent to clean it up.

DrewAPicture2 years ago

Better spacing and $args array

DrewAPicture2 years ago


comment:4 DrewAPicture2 years ago

  • Cc xoodrew@… added

Patch attached (twice?) with better spacing and $args array.

comment:5 nacin2 years ago

  • Milestone changed from 3.4 to Future Release

comment:6 dd3218 months ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #22205.

Note: See TracTickets for help on using tickets.