WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 18 months ago

#19807 closed defect (bug) (worksforme)

Clicking Preview in Multisite Creates 404 Error

Reported by: oateslarsen Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3.1
Component: Multisite Keywords: reporter-feedback
Focuses: Cc:

Description

Since upgrading to Multi-Site, we've had an ongoing problem with individual blog owners being able to click on the Preview button to see how a draft item will appear before being published.

It seems this is specific to when network mode is enabled.

Upon further research, I found the following that clears up the problem:

go to the file template-loader.php in wp-include folder and comments the line number 7 which should be do_action('template_redirect'); so please make it like this

//do_action('template_redirect');

and it will sort out preview post issue in multisite setup. 

Indeed this does resolve the issue, however I HATE tweaking core files. I have searched within WordPress.org Forums as well as for any existing bugs here and was unable to find this registered as a "bug" nor could I find an answer to the problem within the Forum, so I wanted to be sure it is logged.

Andrea_r said to post here.

Thanks

Change History (5)

comment:1 SergeyBiryukov2 years ago

Sounds similar to #16776 and #18069.

comment:2 SergeyBiryukov2 years ago

  • Component changed from General to Multisite

comment:3 wonderboymusic18 months ago

  • Keywords reporter-feedback added

Steps to reproduce in trunk? Otherwise, works for me

comment:4 wpmuguru18 months ago

  • Keywords close added

As a guess, this may have been a domain mapping related report. When 3.3 was released preview stopped working on installs that did not have the lastest version of domain mapping.

Suggesting we close until someone can provide some details.

comment:5 SergeyBiryukov18 months ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Severity changed from critical to normal
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.