WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#19837 closed defect (bug) (duplicate)

Appearance > Menus taxonomy hierarchy problem with great amount of taxonomies

Reported by: jannesmannes Owned by: info@…
Milestone: Priority: normal
Severity: normal Version: 3.3.1
Component: Menus Keywords:
Focuses: Cc:

Description

Hi, I encountered this problem a while ago and it is really hard to work with.

The situation
I made a custom post type, called "products". Then I made a taxonomy called "bikes", with a list of terms describing the type of bikes (e.g. "sportbikes" or "for kids"), and a second dimension of terms with the brands. Just to make clear:

Bikes

  • Sport bikes
    • Target
    • Sensa
  • For kids
    • Alpina
    • Loekie

The problem
The problem is that the list grew to a total amount of 79 terms, which is quite a lot, I know. If I go to Appearance > Menu I see this box called "Bikes" showing the recent used terms. But if I want to see all the terms, the list does not handle the hierarchy of the terms. Since a "sub" term can have the same name as another sub term (the brand "Sparta" can be under "City bikes" but also under "Lifestyle bikes") and they are not listed hierarchycal under the "head" term, I can not see which sub term belongs to a head term.

The solution
Untill now, I have not been able to find a solution in the WordPress fora or on Google.

Change History (4)

comment:1 scribu2 years ago

I am certain this issue was already reported in another ticket, but I can't find it.

comment:2 SergeyBiryukov2 years ago

Sounds related to #18271 and #18282.

comment:3 jannesmannes2 years ago

Ticket #18282 is the same problem, allthough I guess this is just a fix untill the next update.

comment:4 SergeyBiryukov2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.