WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#19850 closed enhancement (fixed)

double slash in URL when editing gallery in visual mode

Reported by: h8every1 Owned by: azaozz
Milestone: 3.4 Priority: normal
Severity: normal Version: 2.7
Component: Gallery Keywords: has-patch
Focuses: Cc:

Description

reproduce:

  1. upload images
  2. insert gallery into the editor
  3. in "Visual" mode hover over the gallery placeholder and click the edit button
  4. a pop-up shows, which URL is 'wp-admin//media-upload.php'

it works all right with vanilla install, but with some anti-hacker enhancements to .htaccess (5G Firewall) it breaks because of double slash.

Attachments (1)

19850.patch (817 bytes) - added by SergeyBiryukov 2 years ago.

Download all attachments as: .zip

Change History (5)

SergeyBiryukov2 years ago

comment:1 SergeyBiryukov2 years ago

  • Keywords has-patch added
  • Milestone changed from Awaiting Review to 3.4

According to TinyMCE documentation, documentBaseURL must end with a slash, so the additional slash is not needed.

Seems that the compressed file is always loaded (regardless of SCRIPT_DEBUG), so in order to test the patch I had to alter wpgallery/editor_plugin.js as well.

There's also a support forum thread about this issue.

comment:2 SergeyBiryukov2 years ago

  • Version changed from 3.3.1 to 2.7

comment:4 azaozz2 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In [20519]:

Remove extra slash when opening the gallery thickbox popup from the visual editor, props SergeyBiryukov, fixes #19850

Note: See TracTickets for help on using tickets.