WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 11 months ago

#19885 closed defect (bug) (wontfix)

Feed wfw Namespace no longer valid

Reported by: ajwagner777 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3.1
Component: Feeds Keywords: has-patch close
Focuses: Cc:

Description

Related to this post http://wordpress.org/support/topic/rss-feed-wellformedweborg-offline?replies=2

A broken link scan of our website revealed that the link in the feeds to http://wellformedweb.org/CommentAPI/ (for the wfw namespace) is invalid. Going to that website reveals that the site has been taken down by the hosting company.

I found 2 references to that namespace in /wp-includes/feed-rss2.php and /wp-admin/includes/export.php and removed them, and the instances to the wfw namespace within the feed content. This fixed my issue.

This begs the larger question: should this be removed/replaced in the core if the site that references the namespace is no longer available?

Verified here: http://ww2.aaronwagner.net/feed/

Attachments (1)

19885.diff (557 bytes) - added by solarissmoke 3 years ago.
Remove unused wfw namespace from export xml

Download all attachments as: .zip

Change History (4)

comment:1 @nacin3 years ago

It's a shame that wellformedweb.org is down, but a namespace URL does not need to resolve. It may look like a URL, but it is just a unique identifier of the namespace. A validating parser would benefit from URL resolution, but that's it.

Not sure why we have wfw referenced in the export, as it is only used in feed-rss2.php for wfw:commentRss. Removing the namespace reference there will result in invalid XML.

comment:2 in reply to: ↑ description @solarissmoke3 years ago

  • Keywords has-patch close added

A broken link scan of our website revealed that the link in the feeds to http://wellformedweb.org/CommentAPI/ (for the wfw namespace) is invalid. Going to that website reveals that the site has been taken down by the hosting company.

I think the problem is that your link checker is trying to resolve/visit XML namespace URIs, which it shouldn't?

Patch removes the wfw namespace from the export file (guessing it was copied over by mistake), although presumably there is no harm in leaving it there either.

@solarissmoke3 years ago

Remove unused wfw namespace from export xml

comment:3 @wonderboymusic11 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Marked close 2 years ago.

Note: See TracTickets for help on using tickets.