WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#19911 closed defect (bug) (fixed)

Menu order not displayed properly for non-hierarchical post types in the inline editor

Reported by: nikolay.yordanov Owned by: duck_
Milestone: 3.4 Priority: normal
Severity: normal Version: 3.3.1
Component: Posts, Post Types Keywords: has-patch
Focuses: Cc:

Description

It is possible to register a non-hierarchical post type with support for page-attributes. This adds a menu order field in the post editor and the inline editor. While everything is working as expected in the post editor, when using the inline editor the menu order in the inline editor is always shown as 0. It is possible, however, to edit it and the changes are visible in the normal editor.

The problem is that the correct menu order is displayed only when the post type is hierarchical. Moreover, the inline-edit-post script updates the menu order only for pages. The attached patch fixes this issue.

Attachments (1)

menu-order.patch (1.4 KB) - added by nikolay.yordanov 2 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 markoheijnen2 years ago

  • Cc marko@… added

comment:2 SergeyBiryukov2 years ago

  • Milestone changed from Awaiting Review to 3.4

comment:3 duck_2 years ago

  • Owner set to duck_
  • Resolution set to fixed
  • Status changed from new to closed

In [19929]:

Display menu_order value in quick edit for non-hierarchical post types. Props nikolay.yordanov. Fixes #19911, see #18352.

Note: See TracTickets for help on using tickets.