WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 7 years ago

#19917 closed defect (bug) (duplicate)

TinyMCE Removes P tag from Table Cells

Reported by: cyberram Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3.1
Component: Formatting Keywords:
Focuses: Cc:
PR Number:

Description

After a page is saved using TinyMCE editor, it removes the first P element inside every cell and replaces it with its inner HTML.

To recreate this issue follow these steps.

  1. Edit any page and paste the below code in HTML view

<table><tr><td><p><strong>Line 1</strong></p><p><strong>Line 2</strong></p><p><strong>Line 3</strong></p></td></tr></table>

  1. Save it and you will notice the first P is removed.
  2. Save it again and the second P tag is removed.

Not sure whether its a bug with the TinyMCE or its implementation in Wordpress.

Tested using Google Chrome and IE, same results.

Change History (2)

#1 @Otto42
7 years ago

See #20943.

Also possibly relevant: #6485.

#2 @SergeyBiryukov
7 years ago

  • Component changed from Editor to Formatting
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #20943.

Note: See TracTickets for help on using tickets.