WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 9 months ago

Last modified 9 months ago

#19960 closed defect (bug) (invalid)

Problem posting by email from MailChimp

Reported by: sooskriszta Owned by:
Milestone: Priority: normal
Severity: major Version: 3.3.1
Component: Blog by Email Keywords: reporter-feedback
Focuses: Cc:

Description

Blog by email seems to have a strange bug.

If I try to post something by email from my gmail account, it works fine. But if I send the email via MailChimp, the posting doesn't work. No post is created, published or draft...it's as if the mail was never received by WordPress

This applies to both self-hosted WordPress and wordpress.org

I have tried doing the same thing with other services such as blogger.com, and it works fine there.

Change History (7)

comment:1 solarissmoke2 years ago

  • Keywords reporter-feedback added

Can you verify that the message sent from Mailchimp is hitting your Post By Email mailbox (i.e., access the mailbox yourself and check that it's there) and then supply the headers of such a message that failed to trigger a post?

comment:2 sooskriszta2 years ago

How/where can I check the Post By Email mailbox?

comment:3 solarissmoke2 years ago

In Settings -> Writing you will have specified a mail server and mailbox which WordPress periodically checks for new messages. You need to access that mailbox yourself using a mail client/webmail and see whether the messages are actually arriving there.

comment:4 daveofdc20 months ago

I do have this problem. I did series of tests -- I even tested from my personal email and several other email accounts. I was able to posted my tested emails fine.

When Mailchimp is send to Post by Email, I got blank post in Page. When I checked the source in Page, my header is there but no content in the body of the email sent by MailChimp.

There was no footer from Mailchimp. When looking at codes in Source, I'm not showing anything after header. I went back to HTML and I'm still showing nothing – no header.

I checked our Mailbox and the email from MailChimp is still there and I was able to see everything when opened (I set the option to leave the copy in mail server).

I even had Postie plugin and nothing worked since the WordPress was upgraded to 3.0. Postie works if I send directly from my personal email account.

I hope you will be able to fix this when you release 3.5 soon.

comment:5 nacin20 months ago

Can you upload a text file of the raw email as received by a mail client, including message headers and all parts?

comment:6 avryl9 months ago

  • Resolution set to invalid
  • Status changed from new to closed

No feedback from reporter(s). Feel free to reopen.

comment:7 ocean909 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.