Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#19983 closed defect (bug) (invalid)

Plugin API return "false" instead of serialized data

Reported by: plugpress Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: WordPress.org site Keywords:
Focuses: Cc:


When querying api.wordpress.org to get some plugins info, there is one case where the expect result is a serialized string but instead, it return false.

An example of how to reproduce the bug is provided in the file.

Please note that...

  • $page variable may need to be incremented.
  • Commenting line 17 will make the query work.

It seems like the bug is when serializing the data from field "sections".

Attachments (1)

worpdress_plugin_api_bug.php (1022 bytes) - added by plugpress 4 years ago.

Download all attachments as: .zip

Change History (4)

#1 @nacin
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

These APIs were never designed for how you are using them — to scrape out data and use them for your own commercial purposes, to create your own parallel repository or "app store" of other people's work.

Looks like there was an issue with the data of a plugin on that particular page.

#2 @plugpress
4 years ago

I do not think this is the right place for that kind of comment or debate. If you have a problem (whatever it is) about PlugPress and/or its goal, please email me directly and we can check it out.

For the record, I contacted you (WordPress.org team) to see what could be done but you decided to change the plugins' rules, ban the plugin "permanently", not answer my last email and close the file without letting me explain or adjust.

#3 @nacin
4 years ago

Storefronts are not accepted for inclusion in the repository. We've been enforcing that guideline for years.

Note: See TracTickets for help on using tickets.