WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 17 months ago

#20050 closed defect (bug) (duplicate)

Proper Cap check in edit_comments.php

Reported by: nprasath002 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3.1
Component: Comments Keywords: has-patch
Focuses: Cc:

Description

See #20025.
As in edit.php?post_type=custom_post_type
and edit-tags.php?taxonomy=custom_taxonomy

When filtering comments for a specific post type
The fix in cap is more appropriate

Attachments (1)

edit_comments.patch (1.0 KB) - added by nprasath002 3 years ago.
cap check in edit_comments.php

Download all attachments as: .zip

Change History (3)

@nprasath0023 years ago

cap check in edit_comments.php

comment:1 @nprasath0023 years ago

The patch want work. If there in no post type defined.
This requires some more work. Will update the patch

comment:2 @johnbillion17 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

I'm going to close this as a dupe of #12104 which is addressing more granular comment capabilities. Feel free to re-open if you don't agree.

Note: See TracTickets for help on using tickets.