WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#20058 closed defect (bug) (duplicate)

XMLRPC: Post excerpt should only be updated if one was provided in metaWeblog.editPost

Reported by: mrroundhill Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3.1
Component: XML-RPC Keywords: has-patch mobile close
Focuses: Cc:

Description

I received a bug report for the WPAndroid app that said the post excerpt would be deleted when a user edited an existing post on their blog. The app doesn't deal with the post excerpt at all so it doesn't pass anything back in the mt_excerpt field in the metaWeblog.editPost call.

I'm going to fix this by passing back the mt_excerpt from the app, but I think it would be best for the API to only update the excerpt if one was provided. I've created a patch that does this.

Attachments (1)

class-wp-xmlrpc-server.php.diff (621 bytes) - added by mrroundhill 6 years ago.

Download all attachments as: .zip

Change History (6)

#1 @redsweater
6 years ago

Assuming the API doesn't already behave this way, I agree this is a good fix, and is consistent with the way other omitted values behave in the API. In general: Omitted? Leave the value alone. Value (even if blank)? Overwrite.

#2 @westi
6 years ago

This should be fixed by [20322] can you test?

#3 @SergeyBiryukov
6 years ago

Seems to be a duplicate of #20321, which outlines and fixes the larger issue.

#4 @markoheijnen
6 years ago

  • Keywords close added

Can't this be closed since the exact code was in [20322]?

#5 @SergeyBiryukov
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.