WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 8 months ago

Last modified 8 months ago

#20073 closed defect (bug) (worksforme)

When I publish a draft the posting date is not updated

Reported by: ccolotti Owned by:
Milestone: Priority: normal
Severity: major Version: 3.3.1
Component: Editor Keywords: reporter-feedback
Focuses: Cc:

Description

I believe this was a bug previously that has come back with the latest version. If you create a draft post and edit it over time, then publish it the date is NOT automatically adjusted to the date you publish. It keeps the original date the post was created as a draft, thus putting it behind in the RSS feed and on your posting list. This used to be an issue before, and seemed to be corrected and has come back up again

Steps to re-produce:
1) Create a draft today
2) Wait a couple days then publish
3) You will see the "published Date" is the date it was created NOT the date it was published

This also happens with scheduled publishes

Change History (8)

comment:1 scribu2 years ago

  • Cc scribu added

comment:3 ccolotti2 years ago

I should be specific. I never use quick edit, so it could certainly be related. I only use and noticed this in the full edit mode.

comment:4 Ipstenu2 years ago

  • Cc ipstenu@… added

comment:5 solarissmoke2 years ago

  • Component changed from Post Types to Editor
  • Keywords reporter-feedback added; needs-testing removed

I can't reproduce this in WP 3.3/trunk. If I create a draft, come back to it later and publish, then the published time is now. I've also checked the database and the post_date is not set on the draft until it is published.

Can you confirm that this happens on a clean install with no plugins active?

Only exception is if you create a draft, publish it, and then change it to a draft again. In this case the first publishing date is saved and you have to change it manually if you want it to be different. But this I believe has always been the case.

comment:6 ccolotti2 years ago

I do not have a place to do a fresh install. This is an upgraded instance from previous versions. Not sure is doing a "Re-Install" from the UI would do anything to change it but it has been pretty consistant since upgrading to 3.3.1

I have drafts sitting there that were always drafts to begin with. Just the dates do not change when published. This is also a Multi-Site install so maybe that has something to do with it?

Either way I keep forgetting to change the date before I publish and that is messing up my RSS feeds.

I did check the DB and they are showing "Draft" but there is a post date assigned but post_GMT is 00000000

Last edited 2 years ago by ccolotti (previous) (diff)

comment:7 avryl8 months ago

  • Keywords needs-patch 2nd-opinion removed
  • Resolution set to worksforme
  • Status changed from new to closed

Tested in 3.6 and works fine. Are you still experiencing this issue? Feel free to reopen.

comment:8 ocean908 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.