WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#20100 closed enhancement (duplicate)

Inconsistent menu visibility for Mobile Safari devices

Reported by: johnbillion Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.3.1
Component: Administration Keywords: has-patch
Focuses: Cc:

Description

When using a device running Mobile Safari the 'Add New' menu under 'Media' is not shown (as iOS devices typically can't upload files). However this is the only place this menu is hidden. This menu is still shown in the admin toolbar and the 'Add New' link is still shown in the Media Library.

Attachments (1)

20100.patch (1.4 KB) - added by johnbillion 2 years ago.

Download all attachments as: .zip

Change History (7)

johnbillion2 years ago

comment:1 johnbillion2 years ago

  • Keywords has-patch added

Patch

comment:2 follow-up: nacin2 years ago

$is_iphone also detects some other mobile safari devices, some of which (like android) might have the capability to upload files. We should probably improve $is_iphone's detection.

comment:3 in reply to: ↑ 2 johnbillion2 years ago

Replying to nacin:

$is_iphone also detects some other mobile safari devices, some of which (like android) might have the capability to upload files. We should probably improve $is_iphone's detection.

I agree. This was the most simple fix.

comment:4 SergeyBiryukov2 years ago

  • Milestone changed from Awaiting Review to 3.4

Sorry I didn't search for existing tickets before opening #20405.

Some mobile devices indeed have the capability to upload files. With wp_is_mobile(), the check isn't limited to Safari. Since [20417], it's no longer possible to upload files using Opera Mini on Windows Mobile.

I guess we can use this ticket to improve iPhone/iPad detection.

comment:5 johnbillion2 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Closing this as a dupe of #20405 as the issue has been addressed with a patch and a changeset there.

I've opened #20410 to address improvements to device capability detection.

comment:6 SergeyBiryukov2 years ago

  • Milestone 3.4 deleted
Note: See TracTickets for help on using tickets.