WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 16 months ago

#20112 closed defect (bug) (worksforme)

Visual editor damages edited text

Reported by: spoko_ws Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3.1
Component: Editor Keywords: reporter-feedback
Focuses: Cc:

Description

I've written a page in internal HTML editor. When I update the page, it appears with some additional characters taken from the inside of the message. I can not force it to save exactly what I write inside, no matter how often I update the page. I'm including the whole page, such that you can reproduce the problem.

Attachments (1)

page.txt (9.3 KB) - added by spoko_ws 2 years ago.
The page, which I cannot save clearly into database

Download all attachments as: .zip

Change History (5)

spoko_ws2 years ago

The page, which I cannot save clearly into database

comment:1 azaozz2 years ago

  • Keywords close added; needs-patch removed

It seems your external HTML doesn't conform to the requirement neither for the visual editor nor for the HTML editor. The problem is with autop: you either use it and replace all <p> tags with line breaks or you don't use it and strip all line breaks from the HTML code (as the visual editor would do).

In reality autop allows line breaks after the closing tags for block elements but nowhere else.

Version 0, edited 2 years ago by azaozz (next)

comment:2 Ipstenu2 years ago

See also: #16239

comment:3 azaozz2 years ago

  • Keywords reporter-feedback added; close removed

comment:4 ocean9016 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Tested in 3.5 with Twenty Twelve. Couldn't see any additional characters. Visual, Text and preview looks the same.

Note: See TracTickets for help on using tickets.