WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#20112 closed defect (bug) (worksforme)

Visual editor damages edited text

Reported by: spoko_ws Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3.1
Component: Editor Keywords: reporter-feedback
Focuses: Cc:

Description

I've written a page in internal HTML editor. When I update the page, it appears with some additional characters taken from the inside of the message. I can not force it to save exactly what I write inside, no matter how often I update the page. I'm including the whole page, such that you can reproduce the problem.

Attachments (1)

page.txt (9.3 KB) - added by spoko_ws 3 years ago.
The page, which I cannot save clearly into database

Download all attachments as: .zip

Change History (5)

@spoko_ws3 years ago

The page, which I cannot save clearly into database

comment:1 @azaozz3 years ago

  • Keywords close added; needs-patch removed

It seems your external HTML doesn't conform to the requirement neither for the visual editor nor for the HTML editor.

Scratch that, think I misread the ticket. The attached html code is taken from the HTML editor and seems to show properly in the visual editor (except one irregularity where a nested table pushes the content of other cells lower, but that depends on the styling).

Can you show what characters shouldn't be there? Include screenshot(s) if needed.

Last edited 3 years ago by azaozz (previous) (diff)

comment:2 @Ipstenu3 years ago

See also: #16239

comment:3 @azaozz3 years ago

  • Keywords reporter-feedback added; close removed

comment:4 @ocean903 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Tested in 3.5 with Twenty Twelve. Couldn't see any additional characters. Visual, Text and preview looks the same.

Note: See TracTickets for help on using tickets.