WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#20128 closed defect (bug) (worksforme)

Some 404 errors when having corrupted URLS!

Reported by: grabbou Owned by: grabbou
Milestone: Priority: normal
Severity: major Version: 3.3.1
Component: Rewrite Rules Keywords: needs-testing 2nd-opinion dev-feedback
Focuses: Cc:

Description

Hi.

I don't know where these urls are being genereated but look:

  1. ?paged=[random string/numbers]

http://blog.seo-profi.pl/?paged=dascas
http://blog.seo-profi.pl/?paged=2123312312
http://wordpress.org/news/?paged=dalsdkalsdk

shows index.php instead of 404.php -> generating multpile DC content which is not good for my seo sites.

  1. When added to the end of article eg. ?p=adasdasdas or ?p=2312312

http://blog.seo-profi.pl/wywiad-z-kasparem-szymanskim-guglarzem-luty-2012/?p=dasdaspdapspd

it redirects me (301) to entire article (which is good) but works for me only after installing 'platinum seo pack'

Unfortunatelly, when added to page permalink, situation from point 1 happens.

Look what is in google :

http://www.google.pl/search?q=site%3Ahttp%3A%2F%2Fchaudesonline.com%2F&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:pl:official&client=firefox-a#q=site:http://chaudesonline.com/&hl=pl&client=firefox-a&hs=buO&rls=org.mozilla:pl:official&prmd=imvns&ei=lqpLT6bHDISZOrytyOMF&start=80&sa=N&fp=1&biw=1280&bih=888&cad=b&bav=on.2,or.r_gc.r_pw.r_cp.,cf.osb

Yes, adding 301 redirect to Home Page in files 404.php, archive.php, index.php helps a bit, but it is not a proper fix.

Any ideas what is going on?

I don't know what is generating these urls! Try adding these to your blogs!

blog.wordpress.org have the same problem!

Change History (4)

comment:1 grabbou2 years ago

The problem is that these corrupted links are being indexed in minor search engines like google or yahoo

comment:2 grabbou2 years ago

  • Owner changed from me and some public blogs for testing purposes to grabbou
  • Status changed from new to accepted

comment:3 Ipstenu2 years ago

  • Resolution set to worksforme
  • Status changed from accepted to closed

Unless you're going to be the person who writes the code o fix this, you shouldn't be assigning it to yourself. The 'owned by' means thats who's owning the work to fix it.

This works as expected for me, out of the box, on a vanilla WP site.

When added to the end of article eg. ?p=adasdasdas or ?p=2312312

?p= whatever is what's used for ugly permalinks, so if you're making up your own plugin to mess with that, I can see issues. I think you've got a theme or plugin issue going on, and should post for support in the forums.

comment:4 SergeyBiryukov2 years ago

  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.