WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 6 years ago

Last modified 5 months ago

#2015 closed defect (bug) (invalid)

Solves "smartquote" formatting issue

Reported by: hayfordoleary Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.0
Component: Administration Keywords: reporter-feedback
Focuses: Cc:

Description

When an item is copied from Microsoft Word -- or any app that automatically creates smart quotes -- WordPress prints the crude symbol into the HTML, causing encoding issues.

Attachments (1)

formatting.txt (685 bytes) - added by hayfordoleary 10 years ago.
The basic dealio. Pardon the poor Trac formatting.

Download all attachments as: .zip

Change History (18)

@hayfordoleary10 years ago

The basic dealio. Pardon the poor Trac formatting.

comment:1 @abhay10 years ago

  • Keywords smartquotes tinymce bg|has-patch added

comment:2 @davidhouse10 years ago

  • Keywords bg|needs-testing added

comment:3 @Nazgul8 years ago

  • Keywords needs-patch added; tinymce bg|has-patch bg|needs-testing removed
  • Milestone set to 2.4

Patch is stale.

comment:4 follow-up: @pishmishy8 years ago

I'm tempted to close this ticket as i believe the issue to be larger than just smart quotes. "WordPress allows users to insert text which isn't supported by the current character set" may be more accurate :-)

comment:5 in reply to: ↑ 4 @santosj8 years ago

Replying to pishmishy:

I'm tempted to close this ticket as i believe the issue to be larger than just smart quotes. "WordPress allows users to insert text which isn't supported by the current character set" may be more accurate :-)

Wow, you are talking extreme difficulty.

comment:6 @santosj8 years ago

Actually.

  1. This is easily solved by switching to UTF-8 encoding. I've tested this and know that it works. I have a site that uses WordPress (2.3.1) and has no problem with people copying Word Documents.
  1. If I didn't want them to submit those characters, I would easily write a plugin that strips out those characters and replace them. However, I don't wish for this to be the normal behavior, since well, if I do have UTF-8 encoding, then it won't make a difference to me. However, I didn't then yeah, I would want those characters stripped out.

comment:7 @pishmishy8 years ago

I'm in complete agreement with you there. WordPress should make sure that the contents of a post are valid characters in the current character set, or it can be left to plugins.

I think we should close this ticket and leave it to someone to raise that as another ticket if it's something they care about.

comment:8 @santosj8 years ago

Correction.

ISO-8859-1 automatically converts the smart quotes over, go figure. There might be some relevance of this ticket after all. I'll go over and try to create a patch, but this field is out of my reach, so I'm unsure how successful I'd be.

comment:12 @thee177 years ago

  • Milestone changed from 2.5 to 2.6

comment:13 @Denis-de-Bernardy6 years ago

  • Keywords smartquotes removed

wonfix?

Related: #8285

comment:14 @hakre6 years ago

  • Keywords reporter-feedback added; needs-patch removed

I am unable to reproduce that at all. Either wontfix or worksforme. Anyway, a step by step instruction on how to reproduce is missing. What are "smart quotes"? I think this term is pretty misleading.

comment:15 @scribu6 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Probably not current anymore.

comment:16 @scribu6 years ago

  • Milestone 2.9 deleted

comment:17 @slackbot5 months ago

This ticket was mentioned in Slack in #accessibility by rianrietveld. View the logs.

Note: See TracTickets for help on using tickets.