WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 20 months ago

Last modified 20 months ago

#20153 closed feature request (wontfix)

Track Plugin actions/history

Reported by: SecGen Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Plugins Keywords:
Focuses: Cc:

Description

It would be great if WP could track any activity around plugins, eg. install, activate, disable, update, delete.

Seeing as plugins are most often the causes of problems with WP, it would be good to know which was the last plugin activated, or updated, particularly on sites with many plugins.

For example, I'm currently troubleshooting a problem which may be due to a plugin I recently updated, however I have no idea which one it could be, and disabling/re-enabling all plugins is not really the best solution.

A fairly simple nice-to-have that would greatly aid troubleshooting.

Change History (6)

comment:1 @c3mdigital20 months ago

  • Component changed from General to Plugins
  • Resolution set to wontfix
  • Severity changed from minor to normal
  • Status changed from new to closed

This is something that would be better suited for a plugin than in core. This is something that would need extensive UI and back end work.

comment:2 @SergeyBiryukov20 months ago

  • Milestone Awaiting Review deleted

comment:3 @SergeyBiryukov20 months ago

  • Type changed from enhancement to feature request

comment:4 @DrewAPicture20 months ago

  • Cc xoodrew@… added

comment:5 @nacin20 months ago

I think this would be a fantastic plugin. And http://wordpress.org/plugins/audit-trail/ might handle it for you already.

comment:6 @DrewAPicture20 months ago

Also, I've used this plugin to track activation/deactivation dates: http://wordpress.org/plugins/plugin-activation-date/

Note: See TracTickets for help on using tickets.