WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#20184 closed defect (bug) (fixed)

Default font in the Visual Editor has changed to sans-serif

Reported by: mfields Owned by: azaozz
Milestone: 3.4 Priority: normal
Severity: major Version: 3.4
Component: Editor Keywords:
Focuses: Cc:

Description

The default font for the visual editor in trunk has recently changed from a Georgia stack to sans-serif. I believe this is a regression and I was able to track it down to the following changeset [19982]

This may be hard to see on a stock install of trunk running Twenty Eleven. The reason for this is that Twenty Eleven provides a custom stylesheet for the Visual Editor. To see what I am talking about, you will need to install a theme that has no editor stylesheet.

Here is what text in the Visual Editor looks like in 3.3.1
https://img.skitch.com/20120306-mit6esawu36pyii8g8us5brh5a.png

Here is what test looks like in the latest trunk:
https://img.skitch.com/20120306-8bn6jtui47n5xbym6fyd2pd16h.png

Removing the font styles from the body element in wp_theme/content.css seems to do the trick. Not sure if this is the best approach. Patch to follow.

Attachments (1)

20184.diff (463 bytes) - added by mfields 6 years ago.

Download all attachments as: .zip

Change History (4)

@mfields
6 years ago

#1 @nacin
6 years ago

  • Milestone changed from Awaiting Review to 3.4
  • Owner set to azaozz
  • Severity changed from normal to major
  • Status changed from new to assigned

#2 @azaozz
6 years ago

In [20125]:

Revert change to the default font in the visual editor, see #20184

#3 @azaozz
6 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

This bit was a left-over from testing a better default font that would work well in all languages when the theme doesn't overwrite the fonts through editor-style.css. Opened #20186 for that.

Note: See TracTickets for help on using tickets.