WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 7 months ago

#20186 closed enhancement (worksforme)

Default font in the Visual Editor doesn't work well in all languages

Reported by: azaozz Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: TinyMCE Keywords: reporter-feedback
Focuses: Cc:

Description

As the title. This is somewhat unnoticed as most themes seem set the fonts there with editor-style.css. However we would need a default that works well for themes that don't set that.

Change History (7)

comment:1 @tsiger3 years ago

Speaking of the visual editor, in Twenty Eleven the default font-weight for copy (both in the visual editor and the theme) is 300 and Greek characters don't respect this weight. Here's an example

http://cl.ly/0C2T173a432b193A0V2a

The problem is that in a long piece of text, it looks like Greek words have a different priority (acting like bold text) which is a bit confusing.

comment:2 @nacin3 years ago

  • Component changed from General to Editor

comment:3 @ryan3 years ago

  • Milestone changed from 3.4 to Future Release

comment:4 follow-up: @johnbillion18 months ago

  • Keywords reporter-feedback added

Can we get some more details on this? Does the issue still apply?

comment:5 in reply to: ↑ 4 @tsiger18 months ago

Replying to johnbillion:

Can we get some more details on this? Does the issue still apply?

This was a TwentyTen issue. Doesn't apply on TwentyFourteen

comment:6 @iseulde7 months ago

  • Component changed from Editor to TinyMCE

comment:7 @azaozz7 months ago

  • Milestone Future Release deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Think we can close this as worksforme now. There are couple of locale specific default fonts now, and we can add more if needed.

Note: See TracTickets for help on using tickets.