WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 11 months ago

#20204 closed defect (bug) (duplicate)

Incorrect links to SSL sites in Multisite

Reported by: johnbillion Owned by:
Milestone: Priority: low
Severity: normal Version: 3.0
Component: Permalinks Keywords: has-patch
Focuses: multisite Cc:

Description

If I create a site in Multisite that has an SSL URL then a few links in Network Admin incorrectly use a non-SSL URL for the site.

Opening this ticket so I don't forget about it. Patch coming up when I have some time.

Attachments (1)

20204.patch (466 bytes) - added by johnbillion 3 years ago.

Download all attachments as: .zip

Change History (7)

@johnbillion3 years ago

comment:1 @johnbillion3 years ago

  • Keywords has-patch added
  • Version set to 3.0

To reproduce:

  • Create a site which uses the 'https' scheme. You can do this by editing an existing site from Network Admin -> Sites.
  • Click 'edit' next to a site.
  • Switch to the Settings tab and alter the 'home' and 'siteurl' options so they start with 'https'.

The link at the top of the same screen will link to the wrong scheme.

Patch attached.

comment:2 @knutsp3 years ago

  • Cc knut@… added

comment:3 @wonderboymusic2 years ago

  • Milestone changed from Awaiting Review to 3.5

comment:4 @nacin2 years ago

  • Milestone changed from 3.5 to Future Release

There are oh so many oddities here. Let's hold off until we can tame some of these get_something_by_something() multisite functions in a single release

comment:5 @jeremyfelt13 months ago

  • Component changed from Multisite to Permalinks
  • Focuses multisite added

comment:6 @SergeyBiryukov11 months ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #14867 and #18931.

Note: See TracTickets for help on using tickets.