Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#20217 closed defect (bug) (fixed)

Webkit + Trunk = Publish immediately format Fugliness

Reported by: Ipstenu Owned by: azaozz
Milestone: 3.4 Priority: normal
Severity: major Version: 3.4
Component: General Keywords:
Focuses: Cc:





Looks fine on Firefox. Looks horrific on Chrome and Safari. Which makes this likely a webkit issue, if I'm not smoking crack. If I 'fix' it for chrome, it looks horrid on Firefox and it's not fixed really for Safari.

This was fine on Friday, which was the last time I remember checking. Still fine today on 3.3 on all three browsers.

Using a Mac.

Attachments (4)

20217.patch (1.1 KB) - added by azaozz 4 years ago.
chrome-17.jpg (16.3 KB) - added by azaozz 4 years ago.
firefox-10.jpg (15.9 KB) - added by azaozz 4 years ago.
opera-11.61.jpg (16.2 KB) - added by azaozz 4 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 @nacin4 years ago

Caused by #17863.

comment:2 @azaozz4 years ago

Yes, seems like a webkit bug. The problem is that the fields aren't wide enough to accommodate webkit's up/down arrows that for some unknown reason are not placed outside of the field's "width" calculation.

comment:3 @azaozz4 years ago

  • Component changed from Editor to General

comment:4 @ocean904 years ago

  • Milestone changed from Awaiting Review to 3.4



And Firefox hasn't implemented it yet, see https://bugzilla.mozilla.org/show_bug.cgi?id=344616

@azaozz4 years ago

@azaozz4 years ago

@azaozz4 years ago

@azaozz4 years ago

comment:5 @azaozz4 years ago

Seems there are two options: either remove type="number" or make these fields wider. 20217.patch is an attempt at the second, it changes it to:

comment:6 follow-up: @nacin4 years ago

When making these fields wider, we're forced to bump the time to the next line. This feels particularly lame. I'd rather we implement a date picker; this really isn't doing much to help things.

comment:7 @Ipstenu4 years ago

A date (and time) picker would be a lot better. +1 nacin :)

comment:8 @ocean904 years ago

Date picker is #7665.

comment:9 in reply to: ↑ 6 @azaozz4 years ago

Replying to nacin:

Yeah, agree it doesn't look well. The problem with date pickers is they all have inherently bad UX: picking a date in the same month is nice and fast, a date 3 months away adds 3 clicks, a date 10 months away ads 10 clicks... Also I haven't seen a nice date + time picker, meaning we will have to make one ourselves.

Perhaps for now it would be best to revert type="number" for these fields.

comment:10 @ryan4 years ago

Revert sounds good.

comment:11 @azaozz4 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In [20217]:

Revert type="number" for the date/time fields as it introduces UI/styling issues, fixes #20217, see #17863

Note: See TracTickets for help on using tickets.