WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 8 years ago

#20221 closed enhancement (duplicate)

Skip Confirmation Email option only visible to Super Admins

Reported by: williamsba1 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4
Component: Users Keywords: dev-feedback has-patch
Focuses: Cc:

Description

When adding a new user in WordPress Multisite, the "Skip Confirmation Email" option is only available to Super Admins.

If you enable the "Add New Users" featured for site admins, they'll have the ability to create new users under Users > Add New. However the "Skip Confirmation Email" option is hidden because they are not a Super Admin.

Super Admins and Admins should have the ability to enable this option when adding new users.

Attachments (3)

user-new.diff (3.1 KB) - added by williamsba1 9 years ago.
user-new.patch (3.1 KB) - added by williamsba1 9 years ago.
user-new.2.patch (3.1 KB) - added by williamsba1 9 years ago.

Download all attachments as: .zip

Change History (12)

@williamsba1
9 years ago

#1 @williamsba1
9 years ago

  • Keywords has-patch added

#2 @bananastalktome
9 years ago

  • Cc bananastalktome@… added

Not to be pedantic, but shouldn't this check add_users rather than manage_options? Also, just to throw this out there, could we allow the super admin to decide whether regular admins can see the "Skip Confirmation Email" option through a setting on the "Network Settings" screen?

#3 @williamsba1
9 years ago

Good point. Updated patch added

#4 @sc0ttkclark
9 years ago

  • Cc lol@… added

#5 @williamsba1
9 years ago

Updated patch to use the promote_users capability, per Nacin's suggestion

#6 @dnaber-de
9 years ago

  • Cc dnaber-de added

#7 @DrewAPicture
9 years ago

  • Cc xoodrew@… added

#8 @knutsp
8 years ago

  • Cc knut@… added

#9 @SergeyBiryukov
8 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #22277.

Note: See TracTickets for help on using tickets.