WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 17 months ago

#20232 closed defect (bug) (worksforme)

Adding custom link / page to menu item renders 500 Internal Server Error

Reported by: spstieng Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3
Component: Menus Keywords: dev-feedback
Focuses: administration Cc:

Description

When I try to add a custom link or page to a menu item, I get a 500 Internal Server Error.

No errors can be found in any log files.

The only reference I have to this bug, is a statement by Mark Jaquith and can be found here: http://wordpress.org/support/topic/rc32-menus-still-crippled?replies=28

I'm not able to find this bug in here, so I'm opening a new ticket.

I had around 40 menu items. After I deleted half of my menu items, I still get this error message.

We have increased memory_limit from 32MB to 300MB We have set max_execution_time from 30 to 60 We have set max_input_time from 60 to 120

We still get this error on both production server and staging server.

I do not get this error on my local dev server running on Virtualbox Ubuntu with 2GB memory.

Change History (7)

#1 @knutsp
6 years ago

  • Cc knut@… added

#2 @robjuurlink
6 years ago

  • Cc robjuurlink added

Could be related to this one (#17031)

Custom menu saving is not efficient. It takes ages to save, resulting in 500 server error (exceeding max execution time).

#4 @chriscct7
3 years ago

  • Focuses administration added
  • Keywords dev-feedback added
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Severity changed from major to normal
  • Status changed from new to closed
  • Version changed from 3.3.1 to 3.3

Someone should probably re-review exactly how much data is sent back on a save, at at what pace does that data grow. So long as it's O(n), and the amount of data on a typical menu item isn't obscene we should close this as invalid. If its large we should find a way to reduce the amount of data. However, with WordPress raising the minimum memory requirements from 32mb to 40mb since this ticket was filed, it's possible that is the cause no one else commented on this issue.

#5 @chriscct7
3 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Whoops. Didn't mean to close that.

Last edited 3 years ago by chriscct7 (previous) (diff)

#6 @SergeyBiryukov
3 years ago

  • Milestone set to Awaiting Review

#7 @dd32
17 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed

A number of things have changed since this ticket was originally reported, and a number of issues related to menu saving still exist. The most common issue that was run into was related to the maximum post variable limits - that's been fixed which fixed a lot of the menu saving issues.

Other issues related to performance of menu saving will be progressively fixed using javascript+rest api menu interfaces.

For now I'm closing this old ticket as worksforme, as it's not a scenario most people run into today.

Note: See TracTickets for help on using tickets.