WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 9 months ago

Last modified 9 months ago

#20252 closed defect (bug) (duplicate)

Default img url when adding media includes "http://etc" causing insecure content in https pages

Reported by: markcunningham Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3.1
Component: Media Keywords: close
Focuses: Cc:

Description

New post, insert media, select an image and have a look at the <img src="" part. It links to the full "http://website/wp-content" address causing images to be loaded as "insecure content" when the full page is loaded via https://website/

If this was instead just "/wp-content/bla", then when the page is loaded via https, all images would by default load with https as well, mitigating against insecure content loading.

Change History (6)

comment:2 kurtpayne2 years ago

  • Cc kpayne@… added

comment:3 solarissmoke2 years ago

  • Keywords close added

There are several tickets related to http/https issues around images. This can probably be closed as a duplicate.

#13941, #15928, #19023, #18005, #19037

comment:4 c3mdigital9 months ago

  • Resolution set to invalid
  • Status changed from new to closed

comment:5 bpetty9 months ago

  • Resolution changed from invalid to duplicate

Duplicate of #15928.

comment:6 helen9 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.