WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#20269 closed defect (bug) (invalid)

Random 404 error on taxonomies

Reported by: retroriff Owned by:
Milestone: Priority: normal
Severity: critical Version: 3.3.1
Component: Taxonomy Keywords: needs-patch
Focuses: Cc:

Description (last modified by dd32)

Hello,

as I explained in the forum, I have detected an strange error with taxonomies. They get a random 404 error when receiving lot of traffic. I have reinstalled a clean WP, removed all plugins, and assigned the WP default theme, but still getting the 404. I have done several tests and my conclusion is that it only happens with custom structure permalinks. For some reason, WP randomly doesn't understand the taxonomy URL and ir server a 404. This is what I get when it works well:

request] => blog/news/the-green-car
[matched_rule] => blog/news/([^/]+)(/[0-9]+)?/?$
[matched_query] => fotos=the-green-car&page=
[did_permalink] => 1

The same taxonomy page shows this when 404:

[request] =>
[matched_rule] =>
[matched_query] =>
[did_permalink] =>

Here some details:

  • It never happens without traffic.
  • It never happens with default permalinks.
  • It never happens with post types, categories, pages or tags, only with taxonomies.
  • It also happens with the default TwentyEleven Theme and with any plugin installed.

I'm very fustrated with this as every day I'm getting thousands of errors. Any suggestion will be apreciated.

Thank you.

Change History (8)

comment:1 dd322 years ago

  • Description modified (diff)

This sounds like MySQL load is getting high, and the rewrite_rules option is failing to load perhaps. I'd suggest this is a server configuration and/or load issue (well, thats obvious..) rather than a WordPress bug, I'd suggest looking into some caching (either Static files for generated content OR a Object cache to remove some of the load from the database such as APC or memcached) depending on actual traffic/server load.

comment:2 retroriff2 years ago

Hello, the server is not overloaded, just 9% cpu, plenty of RAM and low iowait. APC is being used both for opcode and data cache and still having random 404s. Enabling APC cache is even worst because the 404 errors are cached :(

comment:3 retroriff2 years ago

Hello, as this is the first time that I use these tickets, I would like to know if I should wait to receive a solution from the Wordpress team or the the tiocket has been closed. My site manages hugh traffic and we are experiencing big problems with theses 404 errors. Our programmers couldn't find a solution because it looks to be a strange Wordpress behaviour with taxonomies. Thank you.

comment:4 dd322 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Put basically: Trac is not a support avenue, It's used to track active identified bugs, this isn't one. WordPress.org is free software, created and maintained by volunteers, as such, no guarantee's or support such as what you're needing is offered by us.

You can seek support in the WordPress.org forums or consider hiring someone who might be able to debug/investigate the issues you're having, there are plenty of WordPress developers out there (both freelancers, and companies) who deal with large-scale sites.

That being said, I'm almost sure that many sites have most likely exceeded the pageviews/load that you're seeing, and haven't reported similar issues, which strongly points to a server issue, especially given it's load related.

I'm closing the ticket, due to no bugs being identified, If you (or your programming team) find a bug thats causing it, we'd love you to report it, but I've never heard of similar problems, and it's impossible for anyone else to duplicate your issue most likely.

comment:5 Marventus2 years ago

@dd32: Ditto on your last reply.
@retroriff: Have you double-checked your individual post Permalinks to make sure they are pointing to right URL? It is not unlikely for post Permalinks to get messed up after changing your settings.

Last edited 2 years ago by Marventus (previous) (diff)

comment:6 Marventus2 years ago

  • Cc frandeazevedo@… added

comment:7 retroriff2 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

I checked the permalinks and resaves them. About this, the only thing that I can say is that the error doesn't happen with default permalinks.

comment:8 dd322 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

see comment:4 Trac is not a support avenue, and not to just brush you off, but there's nothing here to point to a specific bug in WordPress as there's no steps to reproduce it that can be used reliably.

You may find someone interested in helping debug it in the support forums as mentioned above.

Note: See TracTickets for help on using tickets.