WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

#20286 closed feature request (maybelater)

Allow direct use of top level domains in multisites

Reported by: mickylmartin Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3.1
Component: Multisite Keywords:
Focuses: Cc:

Description

Most people installing the multisite would need top level domains and not the subdomains. The domain mapping plugin doesn't really fit in cause it depends on creating aliases and mappings and works on redirects. Separation is important which i guess is the main purpose of multisiting.

I see default WP setup allows you to rename the site URL once its created. So I did, renamed the subdomain into main domain and got into redirect loop problem. After some searching, it turned out the problem was caused by DOMAIN_CURRENT_SITE in wp-config being static. So I changed it to $_SERVERSERVER_NAME?. This though solved the looping problem but got one more issue. Now going into child site's dashboard requires you to re-login cause of cookie not being set for all child top level domains.

Let's be it - not all people need the subodmain mutisites as you may notice on the forums. Meanwhile, if there's a workaround for setting up cookies for all of the top level sites when logging into network, please advise!

The multisite codex wiki itself tells the same - as a matter of fact it shows a screenshot having a top level domain as a wp site and that was the main reason why I went on choosing mutisite.

Change History (8)

#1 @Ipstenu
7 years ago

Now going into child site's dashboard requires you to re-login cause of cookie not being set for all child top level domains.

That's actually a 'problem' with domain mapping plugins, and I'm 99% sure it's from cross-domain scripting protection (which is to say, it's a bad idea to inherently trust that foobar.com and bazzot.com are okay sharing cookies, and would be something nefarious sorts would abuse).

I'd call it not a bug but a security feature.

#2 @Ipstenu
7 years ago

  • Severity changed from major to normal
  • Type changed from defect (bug) to feature request

#4 @SergeyBiryukov
7 years ago

Related/duplicate: #14564

#5 @SergeyBiryukov
7 years ago

#22513 was marked as a duplicate.

#6 @Bueltge
7 years ago

  • Cc frank@… added

#7 @UMdB
6 years ago

  • Cc UMdB added

#8 @nacin
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to maybelater
  • Status changed from new to closed

We'll get to this at some point in the future, but for now: ​http://wordpress.org/plugins/wordpress-mu-domain-mapping/

Note: See TracTickets for help on using tickets.