WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#20295 closed defect (bug) (worksforme)

Insert gallery options not loading

Reported by: cramdesign Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Gallery Keywords: close
Focuses: Cc:

Description

The options to re-order and insert a gallery do not seem to be loading properly. This happens on a fresh install and no plugins and is repeatable on several sites and different installs.

Using the developer tools in safari, I see that three errors are logged: Failure to load resource and two instances of ReferenceError: Can't find variable: jQuery. I am sorry that I do not know how to track down what is causing this be it a bug or server issue.

This does not occur on another installation that I work with on a different host. This problem has not always been present even with the same host but I am not certain with which upgrade the problem began.

WordPress version is 3.31.

Attachments (1)

Screen-Shot-2012-03-24-at-9.31.40-AM.png (49.3 KB) - added by cramdesign 2 years ago.
Errors shown in web inspector.

Download all attachments as: .zip

Change History (11)

cramdesign2 years ago

Errors shown in web inspector.

comment:1 ocean902 years ago

  • Keywords reporter-feedback added

Failure to load resource

Which resource? jQuery?

comment:2 cramdesign2 years ago

Failed to load resource: the server responded with a status of 404 (Not Found) load-scripts.php

(I would be happy to provide more information or help however I can.)

Last edited 2 years ago by cramdesign (previous) (diff)

comment:3 ocean902 years ago

What happens if you insert define( 'SCRIPT_DEBUG', true ); or define( 'CONCATENATE_SCRIPTS', false ); into your wp-config.php?

comment:4 cramdesign2 years ago

If I insert either of those two scripts, the gallery options appear. Drag re-ordering seems to work. The errors in web inspector no longer show. Seems to be fixed.

Version 0, edited 2 years ago by cramdesign (next)

comment:5 cramdesign2 years ago

  • Keywords reporter-feedback removed

comment:6 cramdesign2 years ago

So, side question? I teach some art students how to publish an online portfolio with WordPress. Being able to insert galleries and rearrange the images in those galleries are important needs. The entire class is having this problem. Should I include this bit of code in the theme functions file which seems like a bit of a hack but works? It seems a bit impractical to have each student edit their config file? Is there a better fix? Is there something the web host is not doing properly but should?

comment:7 helenyhou2 years ago

  • Keywords reporter-feedback added

What ocean90 suggested aren't hacks, but rather more like diagnostic tools :) Are all of the installs that aren't working on the same host? It sounds rather like there is a rule somewhere (probably enforced by the host) that is blocking load-scripts.php.

comment:8 cramdesign2 years ago

Oh yes... I know that they are not hacks in and of themselves but it seems like a bit of a hack to include those lines into my functions.php file. I really appreciate for the help I have received from ocean90.

Yes, they are all with the same hosting company. I have been with them forever and am usually quite happy with them. I am working with them to see if they can sort it out. I'll post what comes of it...

So maybe this won't turn out to be a WordPress bug after all. Though maybe WP should be more adaptive to this problem or at least give some feedback? Not sure...

comment:9 cramdesign2 years ago

  • Keywords close added; reporter-feedback removed

From my web host: "There was code in that script that was triggering a mod_security2 rule. The
rule has been modified to stop the problem." So, the problem is fixed for me. Wish I knew more about it. Thanks ocean90 and helenyhou for your kind attention.

comment:10 helenyhou2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.