WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#20351 closed defect (bug) (duplicate)

Caregories in nav_menu menu are unordered

Reported by: dmaras Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3.1
Component: Menus Keywords: needs-patch needs-testing
Focuses: Cc:

Description

Hello,
When i go on wp admin menu for nav menus there is one bug becouse i have lot (over 110) of categories and they are all unordered, they are not arranged like on Category menu (category->subcategory->subcategory.etc.) they are all like parent categories.
Please can you do something about that. Thank you.

Best Regards,
Dubravko

Attachments (7)

Menu.png (131.2 KB) - added by dmaras 2 years ago.
This is how it look in menu
Category.png (97.2 KB) - added by dmaras 2 years ago.
This is how it look in category menu
20351.menu-hierarchy.png (5.9 KB) - added by SergeyBiryukov 2 years ago.
nav_menu-cats.jpg (4.2 KB) - added by Marventus 2 years ago.
cat test.png (127.1 KB) - added by dmaras 2 years ago.
page 1 on menu
cat test1.png (129.9 KB) - added by dmaras 2 years ago.
page 2 on menu
cat test2.png (135.4 KB) - added by dmaras 2 years ago.
This is how it look on category menu

Download all attachments as: .zip

Change History (21)

dmaras2 years ago

This is how it look in menu

dmaras2 years ago

This is how it look in category menu

comment:1 follow-up: SergeyBiryukov2 years ago

Can't reproduce on my install (20351.menu-hierarchy.png).

Hierarchy for pages and categories in nav menus was added in #17029.

comment:2 in reply to: ↑ 1 dmaras2 years ago

Replying to SergeyBiryukov:

Can't reproduce on my install (20351.menu-hierarchy.png).

Hierarchy for pages and categories in nav menus was added in #17029.

So i need to coppy codes from 17029.3.diff and paste them to my wp-includes/nav-menu.php file? if i understad that good?

comment:3 follow-up: SergeyBiryukov2 years ago

No, that patch is already in core since WordPress 3.2.

Have you tried with Twenty Eleven and all plugins disabled (or on a clean install)?

comment:4 in reply to: ↑ 3 dmaras2 years ago

yes i tried clean install it is all the same...

comment:5 follow-up: Marventus2 years ago

  • Cc frandeazevedo@… added

I can confirm categories are organized on my test install (WP 3.3.1, Twenty-Eleven 1.3). Could this be a L11N issue?

Last edited 2 years ago by Marventus (previous) (diff)

Marventus2 years ago

comment:6 in reply to: ↑ 5 dmaras2 years ago

How many categories do you have? i have 304. Can you tell me what is L11N? :/

comment:7 follow-up: Marventus2 years ago

Yeah, sorry. L11N = Localization. In order to test this, you could create a test install in EN and see if the problem persists. It might seem unrelated, but I've seen issues like this before.
Also, when you reinstalled, did you redownload WP or did you use a local copy? Try redownloading it in case the local copy got corrupted somehow.

Version 1, edited 2 years ago by Marventus (previous) (next) (diff)

comment:8 in reply to: ↑ 7 dmaras2 years ago

I tried reinstall directly on server, and it was all the same, i have also tried on localhost new installation of WP 3.3.1 and 3.2, but when I import all categories from this theme my categories are unorganised. It happens when one of my sub categories go on second page on all categories tab.

comment:9 Marventus2 years ago

Unless you can actually tell us how to replicate that error or pin-point it a little further, there is not much we can do from here (Trac). However, you can post a link to a WP Forums thread and we could try to help you there, although I am stepping out now and won't be available for the rest of the day.
In the meantime, you can try what I suggested about installing WordPress in English either locally or remotely and see it the issue persists.
Another thing you can do is:
1. Install WP from scratch (redownload);
2. DO NOT import your old cats. First create a few, and see if the issue remains;
3. If it doesn't, start creating plenty of bogus cats and regularly check to see if anything breaks. If you reach a similar amount of categories as your site and then the layout breaks, you may be able to prove it is a core issue. If it nothing does break, then there's clearly an issue in your original site.
Other than that, I can't really think of anything else.

Last edited 2 years ago by Marventus (previous) (diff)

comment:10 dmaras2 years ago

I have tested it now on clean instalation on localhost newest version.

dmaras2 years ago

page 1 on menu

dmaras2 years ago

page 2 on menu

dmaras2 years ago

This is how it look on category menu

comment:11 Marventus2 years ago

Hi,

I just now had time to log in Trac. As for your pics, cat_test.png and cat_test2.png look as they should. The only one displaying a problem is cat_test1.png.
How many categories do you have in your test install? Did you install WP in English? I'm emphasizing the latter because you didn't specify this on your last reply.
The bottomline is, as I already mentioned, that unless you can actually reproduce this error from scratch, there's not much I can do for you from here.

comment:12 SergeyBiryukov2 years ago

I can now reproduce with more than 50 categories, which is $per_page value in wp_nav_menu_item_taxonomy_meta_box().

The hierarchy is not preserved on the second page of the meta box.

comment:13 SergeyBiryukov2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

comment:14 Marventus2 years ago

  • Cc frandeazevedo@… removed
Note: See TracTickets for help on using tickets.