WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#20367 closed defect (bug) (invalid)

Twenty Eleven + Category list widget broken in new Chrome

Reported by: zsero Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3.1
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

On a standard Twenty Eleven theme, I have set it up to have the content on the left and the sidebar on the right side. The following widgets are activated in the main sidebar in the following order:

  1. Custom menu
  2. Tag cloud
  3. Categories
  4. NextGen slideshow

The problem is that once I insert the categories widget, the page functionality brakes in new versions of Chrome. The #primary div covers the #secondary div (as normal). The problem is that until #primary covers #secondary (vertically), the <a> links stops working in #secondary. By right clicking / inspect element anywhere on #secondary, the inspector opens up #primary.

The only way I could fix it was to manually reduce the width of the primary div to 700px. I had to insert these two CSS rules to my style.css (using a child theme for minimalist style changes, mostly colors).

#primary {
width: 700px;
margin: 0;
}

#content {
width: 650px;
}

Example URL: http://kek.org.hu/betonretro/
note, that on the above site, I had to apply the last two fixes because it's a live site. To see the bug just untick the above two CSS rules in the inspector.

I believe that this bug is affecting all Twenty Eleven installations, with the newer versions of Chrome. It's a mystery why only the activated widget combination triggers the bug, but it needs a fix.

Change History (5)

comment:1 zsero2 years ago

Chrome version: 18.0.1025.142
OS version: Win 7 64-bit

comment:2 SergeyBiryukov2 years ago

  • Component changed from Themes to Bundled Theme

comment:3 follow-up: rosshanney2 years ago

Removing the following from your stylesheet seems to fix it:

#main {
  min-height: 1000px;
}

I'm not sure why that rule causes this, but it's not a TwentyEleven bug, as far as I can see.

Version 0, edited 2 years ago by rosshanney (next)

comment:4 in reply to: ↑ 3 ; follow-up: zsero2 years ago

Replying to rosshanney:

Removing the following from your stylesheet seems to fix it:

#main {
  min-height: 1000px;
}

I'm not sure why that rule causes this, but it's not a TwentyEleven bug, as far as I can see.

Thanks! Removing min-height does indeed fix it, but then how do I implement min-heigh functionality? It shouldn't cause a bug. Do you think its a bug in Chrome?

comment:5 in reply to: ↑ 4 SergeyBiryukov2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Replying to zsero:

Removing min-height does indeed fix it, but then how do I implement min-heigh functionality?

The bundled theme doesn't have that CSS rule. Since you're using a custom child theme based on Twenty Eleven, this is a support issue.

Please try the support forums: http://wordpress.org/support/

Note: See TracTickets for help on using tickets.