WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#20430 closed defect (bug) (duplicate)

mismatched home and siteurl host distrupts login cookies

Reported by: norcross Owned by: nacin
Milestone: Priority: high
Severity: minor Version: 3.4
Component: Administration Keywords: has-patch needs-testing
Focuses: Cc:

Description

If a user has set their siteurl with a WWW and their home without it (or vice versa), wp-login will redirect multiple times and break the cookie setting. The admin is still accessible, but the user will not stay logged in.

Attachments (1)

options.php.diff (1.4 KB) - added by norcross 2 years ago.
left out the possibility of a port being in the URL. added a check for that

Download all attachments as: .zip

Change History (6)

comment:1 nacin2 years ago

  • Milestone changed from Awaiting Review to 3.4
  • Owner set to nacin
  • Priority changed from normal to high
  • Severity changed from normal to minor
  • Status changed from new to reviewing

comment:2 follow-up: SergeyBiryukov2 years ago

Duplicate of #9873.

Related: #10970 (the patch there also addresses this).

norcross2 years ago

left out the possibility of a port being in the URL. added a check for that

comment:3 in reply to: ↑ 2 norcross2 years ago

Replying to SergeyBiryukov:

Duplicate of #9873.

Related: #10970 (the patch there also addresses this).

My mistake, I searched for related tickets but didn't find those.

comment:4 norcross2 years ago

  • Cc andrew@… added

comment:5 nacin2 years ago

  • Milestone 3.4 deleted
  • Resolution set to duplicate
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.