WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 23 months ago

Last modified 23 months ago

#20454 closed defect (bug) (invalid)

WXR export and Disqus

Reported by: eozyo Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3.1
Component: Export Keywords:
Focuses: Cc:

Description

It came to my attention that the WXR auto-generated file writes the <generator> tag outside the <rss> tag.

Because of this, Disqus doesn't automatically upload comments to their servers and gives the following error:

"XML syntax error: Extra content at the end of the document, line 19 column 1"

If you download the WXR file to your computer and you move the <generator> tag inside <rss> gets the issue fixed.

Change History (3)

comment:1 duck_2 years ago

I cannot reproduce this. wp-admin/includes/export.php does use the function the_generator() outside of the <rss> tag, but since the type is "export" the generator string produced is within an XML comment. The <generator> tag is produced by the_generator() being hooked into the "rss2_head" action which is done within the <rss> tag.

comment:2 nacin23 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

comment:3 SergeyBiryukov23 months ago

  • Keywords needs-patch removed
  • Severity changed from critical to normal
Note: See TracTickets for help on using tickets.