WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#20458 closed defect (bug) (duplicate)

sanitize_title does not sanitize some characters it should

Reported by: conualfy Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3.1
Component: Formatting Keywords: has-patch
Focuses: Cc:

Description

Hello,

I want to tell you that one of the characters used to quote is not sanitized by sanitize_title(): "„". The equivalent ending character ("“") is sanitized, but the opening one was left out.

Have a great day,
Florin

Attachments (1)

20458.patch (713 bytes) - added by SergeyBiryukov 2 years ago.

Download all attachments as: .zip

Change History (3)

SergeyBiryukov2 years ago

comment:1 SergeyBiryukov2 years ago

  • Component changed from General to Formatting
  • Keywords has-patch added; needs-patch removed
  • Milestone changed from Awaiting Review to 3.4

Unit test: [UT687]

comment:2 SergeyBiryukov2 years ago

  • Milestone 3.4 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Actually, a duplicate of #19820.

Note: See TracTickets for help on using tickets.