Make WordPress Core

Opened 12 years ago

Closed 9 years ago

Last modified 19 months ago

#20516 closed enhancement (wontfix)

Ability to remove a previously-used Header Image from the list of rotating "random" header images

Reported by: tomauger's profile TomAuger Owned by:
Milestone: Priority: low
Severity: normal Version: 3.4
Component: Customize Keywords: needs-patch close
Focuses: ui, administration Cc:

Description

Being able to add a bunch of header images and then selecting the "Random" option in the Appearance > Header section is awesome! However, it is equally important to be able to remove one/some/all of those header images from the list of rotating images. The current UI does not support this.

An approach that would be the least disruptive to the current UI layout would be to enable a "remove from list" link (I wouldn't use the word "delete" because it's not deleting the media resource) when the user hovers over the image. The link could appear below the thumbnail, much as the Post's Quick Edit link appear under the list of Posts/Pages.

Attachments (1)

remove-header-patch-01.patch (5.7 KB) - added by tomauger 10 years ago.
First scratch at removing header images

Download all attachments as: .zip

Change History (12)

#1 @SergeyBiryukov
12 years ago

  • Keywords ux-feedback added

#2 @nacin
10 years ago

  • Component changed from Themes to Appearance

#3 @ocean90
10 years ago

  • Focuses ui added
  • Keywords needs-patch added; ux-feedback removed

Yes, please.

#4 @tomauger
10 years ago

I should take a look at this, now that I know a thing or two about a thing or two. I don't know about getting it in in time for 3.9 though.

@tomauger
10 years ago

First scratch at removing header images

#5 follow-up: @tomauger
10 years ago

This initial patch is a quick fix, allowing header images to be removed from the "available images" pool. It has a small jQuery error right now that prevents the user from removing multiple images without a refresh, which I will address in the next update.

The whole header image approach is bogus though and should be completely refactored (see #27202) once we get the Media Modal settled. Currently selecting ANY media library item as a Header Image will automatically create a new attachment, even if it's exactly cropped. So if you remove an image from the list, the next time you add it, your library will get yet another duplicate of that image.

#6 @tomauger
10 years ago

  • Focuses administration added
  • Keywords has-patch added; needs-patch removed

This ticket was mentioned in IRC in #wordpress-dev by TomAuger. View the logs.


10 years ago

#8 in reply to: ↑ 5 @SergeyBiryukov
10 years ago

Replying to tomauger:

Currently selecting ANY media library item as a Header Image will automatically create a new attachment, even if it's exactly cropped. So if you remove an image from the list, the next time you add it, your library will get yet another duplicate of that image.

Related: [20806], #20657.

As noted in IRC, it was designed that way to prevent orphaning header image if the original attachment is deleted (and vice versa).

Currently you can remove an image from the list of available header images by deleting that attachment from Media Library. So I guess the patch should just allow to do that on the Custom Header screen itself.

#9 @ocean90
10 years ago

  • Keywords needs-patch added; has-patch removed

It's now possible in the Customizer to remove an image from the list. It uses the custom-header-remove ajax action, see Custom_Image_Header::ajax_header_remove(). This should be reused.

#10 @celloexpressions
9 years ago

  • Keywords close added
  • Priority changed from normal to low

As of [30459], very few users will be dealing with header images outside of the Customizer. We could still do this for those users (mainly no-js), but I don't think it's worth the effort.

If we do something here, #18959 is related and could possibly end up being a duplicate.

#11 @wonderboymusic
9 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

wontfix since [30459]

Note: See TracTickets for help on using tickets.