Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#20538 closed defect (bug) (duplicate)

remove wp_admin_css from login-site

Reported by: Ninos Ego Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3.1
Component: General Keywords: close
Focuses: Cc:


hey guys,
I have tried all ways to remove
wp_admin_css( 'wp-admin', true );
wp_admin_css( 'colors-fresh', true );

-> wp-admin-css & colors-fresh-css from the login page, but there's no way. I think it's because of the true in the function wp_admin_css..

Maybe in the next version you can change it, because of this styles it's too hard to style your own login page..

Change History (2)

#1 @ocean90
4 years ago

  • Keywords close added

Related: #19130, #14559

#2 @SergeyBiryukov
4 years ago

  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

It should be possible to customize login page by hooking into login_enqueue_scripts action (and using !important in style definitions if necessary):

function customize_my_login_page() {
	wp_enqueue_style('my-login-style', '.../my-login-style.css');
add_action('login_enqueue_scripts', 'customize_my_login_page');

wp_print_styles() needs to be added in this case, since it's not called automatically for login_head. Related discussion: ticket:17916:12.

Closing as a duplicate of #19130.

Note: See TracTickets for help on using tickets.