WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#20580 closed defect (bug) (invalid)

Deprecated Notices break the UI and produce white screen upon Theme activation (3.4-beta3-20634)

Reported by: emiluzelac Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4
Component: Warnings/Notices Keywords: needs-testing
Focuses: Cc:

Description

This ticket was forked from http://core.trac.wordpress.org/ticket/20361#comment:20


  • WP - (3.4-beta3-20634)

When I manually upload the Theme and activate in right away this message shows up:

  • Notice: add_custom_background is deprecated since version 3.4! Use add_theme_support( 'custom-background', $args ) instead. in /wp-includes/functions.php on line 2705
  • Notice: add_custom_image_header is deprecated since version 3.4! Use add_theme_support( 'custom-header', $args ) instead. in /wp-includes/functions.php on line 2705

Just to clear something first; the message isn't tied only to Twenty Eleven Theme used in this example, any Theme with deprecated functions will display.

Now, we're not talking about "standard" notice where this would show on top of the page (just below the admins menu) it breaks the WP completely and it creates a white screen with those two notices or more depending on deprecated functions and Themes.

I am using a fresh WP install and beta tester plugin.

Here's this too http://screencast.com/t/9ceNkTLqriMf

Thanks,
Emil

Change History (9)

comment:1 follow-up: nacin2 years ago

Please upload a zip of the theme you are trying to upload.

Note it is not uncommon for a notice to prevent headers from being sent, and therefore a white screen (or sorts). Additionally, errors should normally be logged, not displayed. This itself isn't a bug. And, as mentioned in #20580, I couldn't reproduce.

comment:2 in reply to: ↑ 1 emiluzelac2 years ago

Replying to nacin:

Please upload a zip of the theme you are trying to upload.

Note it is not uncommon for a notice to prevent headers from being sent, and therefore a white screen (or sorts). Additionally, errors should normally be logged, not displayed. This itself isn't a bug. And, as mentioned in #20580, I couldn't reproduce.

Maximum attachment size: 262144 bytes so I uploaded here http://cl.ly/190k1U3E04463O1J0c1T, hope that's OK.

comment:3 emiluzelac2 years ago

P.S. This is not Theme related, any Theme with deprecated functions will trigger this.

comment:4 nacin2 years ago

Tried again. Cannot reproduce.

Make sure you have disabled all plugins, including Debogger which seems to be active in your screencast.

Because this is very particular to server configurations and development environments, let's see if anyone else can.

comment:5 emiluzelac2 years ago

You stand correct! and the plugin that breaks was bbPress :)

Version 0, edited 2 years ago by emiluzelac (next)

comment:6 nacin2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Great, thanks. I sent a note to JJJ so he could take a look.

comment:7 emiluzelac2 years ago

Sounds good! Sorry for invalid ticket.

comment:8 johnjamesjacoby2 years ago

Both BuddyPress and bbPress will need to be audited in this regard, and both will need point releases to suppress these notices.

The new replacement functions did not previously exist, meaning they weren't doing anything wrong before. Playing catch up when functions are immediately deprecated instead of silently deprecating for a version or two is annoying, but that's what deprecated notices and WP_DEBUG are for; they're notices to developers to update old code.

Thanks for the report, and know that these notices are already fixed in the next major development versions of both BuddyPress and bbPress.

comment:9 emiluzelac2 years ago

No problem, thanks for the explanations :)

Note: See TracTickets for help on using tickets.