WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 19 months ago

#20588 closed enhancement (duplicate)

phpdoc references to filters/actions

Reported by: bananastalktome Owned by:
Milestone: Priority: normal
Severity: minor Version:
Component: Inline Docs Keywords: dev-feedback 2nd-opinion
Focuses: Cc:

Description

I noticed that many of the apply_filters and do_action calls used in functions throughout the codebase are not reflected in the functions doc description. I was not sure if it was a worthwhile task of going through and adding these, or whether this was not really desirable.

If so, is there any preferred syntax by which these should be documented?

Is, for example, this snippet for do_action hooks taken from do_feed() (@uses do_action() Calls 'do_feed_$feed' hook, if a hook exists for the feed.) and, for apply_filters, this snippet from wp_ext2type() (@uses apply_filters() Calls 'ext2type' hook on default supported types.) acceptable template examples?

Change History (5)

comment:1 ocean902 years ago

Related: #16809

(Or a duplicate of the filter part.)

comment:2 bananastalktome2 years ago

Should I hold off on any potential patch attempts on this until after 3.4?

comment:3 nacin2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Yes. I would hold off on any patches. duck_ and I have been discussing a new WordPress docblock standard for actions and filters, which we hope to start come 3.5.

comment:4 bananastalktome2 years ago

Sounds good nacin, excited to hear news of a new standard being discussed (and eager to see it :) )

comment:5 tollmanz19 months ago

  • Cc tollmanz@… added
Note: See TracTickets for help on using tickets.