WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#20599 closed enhancement (duplicate)

Better notice and UX when logged out user tries to post

Reported by: mbijon Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3.1
Component: Administration Keywords: 2nd-opinion ux-feedback
Focuses: Cc:
PR Number:

Description

If you're logged out and try to 'Save Draft' from the Admin, then WordPress displays a small red notice box but you're later redirected to the login screen. The redirect causes you to lose the Draft post (there are browser plugins that help here, but they're not built-in to WordPress).

A better UX for logged out posting is in the P2 theme. It opens a popup saying you're logged out and disables the form posting capability. Can we attempt a similar, more-obvious UX for Admin?

This bug is detailed better here by Daniel Bachhuber:
http://danielbachhuber.com/2012/05/01/notify-when-logged-out/

Change History (4)

#2 @mbijon
8 years ago

  • Summary changed from Better notice and UX when logger out user tries to post to Better notice and UX when logged out user tries to post

#3 @mbijon
8 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Thanks Sergey. I'm marking this a duplicate of #13942

Sorry about the duplication, searching for 'logged out' apparently doesn't show results for 'logged-out' very high up.

#4 @SergeyBiryukov
8 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.