WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 23 months ago

#20632 closed enhancement (duplicate)

Can we solve the Featured Image usability issues?

Reported by: TomAuger Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: UI Keywords:
Focuses: Cc:

Description

Once you're within the Media manager thickbox, the usability for "Set as featured image" drops significantly.

For one thing, if you entered the Media manager through the "Set featured image" link on a post or page, the "Insert into Post" button needs to go - it's not appropriate for this use case and, given that it's bigger, brighter, and shinier than the humble "Set as featured image" link, is likely to be clicked in error. This is a common user error we're observing in new users.

Second, unlike the Appearance > Header Image upload functionality, set featured image does not get a custom crop, which would be extremely useful. Can we borrow from the Header Image process? It seems to make sense, given that the Featured Image is often used as a Header Image.

Change History (6)

comment:1 SergeyBiryukov2 years ago

  • Keywords ux-feedback added

Related: #18708

comment:2 scribu2 years ago

Agreed on removing the "Insert into post" button. It distracts you from what you set out to do.

We can also hide "Default Caption", "Link URL" and "Size" fields, since they're only useful when inserting the image into the post content.

comment:3 helenyhou2 years ago

Also related: #14762

I could see it being more usable to have a gallery/library view that adds a select link/button in the item's "row" that doesn't require expanding the item, provided you came from the "Set featured image" link.

Last edited 2 years ago by helenyhou (previous) (diff)

comment:4 TomAuger2 years ago

Agreed @scribu & @helenyhou.

I think we have one philosophical hurdle to deal with and that's that Feature Images are a bit ambiguous, whereas Header Images are quite clear.

By this I mean that, and maybe it's just a naming thing, a Feature Image is not necessarily a header image. Some themes may choose to implement Header Images theme-wide, but not incorporate the post_thumbnail into their header templates. Perhaps the Feature Image is used elsewhere within the post, or as a thumbnail on archive pages, but not as a bona fide page header. Perhaps we just need to be more consistent in our nomenclature, across the UI ("Featured Image") and the API ("post_thumbnail") and elsewhere in the documentation.

Alternatively, I wonder whether there's a good use case for separating post thumbnails from post headers from featured image.

comment:5 prionkor2 years ago

Also The response from ajax thumbnail set is returns with html. Where it can just return json/xml data with success or fail. And js/jq from response funciton can take care the dom insertion.

Also please add good support for selecting post thumbnail from front end. When adding media upload from front end. If a user (subscriber level) have the capability to upload files/images still can't select the post thumbnail. The response returns with -1.

Last edited 2 years ago by prionkor (previous) (diff)

comment:6 helenyhou23 months ago

  • Keywords ux-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

I think we can close this as a duplicate of #14672. Also related: #19396, #18708, #13522, #12922.

Version 0, edited 23 months ago by helenyhou (next)
Note: See TracTickets for help on using tickets.