WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#20639 closed enhancement (duplicate)

wp-login.php shouldn't ask logged-in users to log in

Reported by: johnbillion Owned by:
Milestone: Priority: low
Severity: minor Version:
Component: Administration Keywords:
Focuses: Cc:
PR Number:

Description

I'm not sure if this is intended behaviour or not (I can't think of a use case), but when a logged-in user visits wp-login.php they are still asked to log in.

They should instead be redirected to the default login redirect location (usually wp-admin).

Change History (2)

#2 @nacin
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

There actually is some hypothetical intended behavior — refreshing cookies, potentially to get SSL cookies issued after having only non-SSL cookies.

See #14949.

Note: See TracTickets for help on using tickets.