Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#20707 closed defect (bug) (duplicate)

Menu name and taxonomy Term conflict

Reported by: thomask Owned by:
Milestone: Priority: normal
Severity: major Version: 3.3.2
Component: Taxonomy Keywords:
Focuses: Cc:


I have created menu with the same name (and slug), as one term in one of my custom taxonomies. I have not noticed it, until i need to rename the menu - it has changed not only the menu, but also the term in that custom taxonomy. And when i renamed the term in taxonomy, it then renames the name.
I think it may be a mayor problem, as it may make big problems for someone as me, who needs exact slug names for his project for some specific definitions and it was not easy to notice it. I had to create new menu with the new name and delete the old one (it does not delete the taxonomy)

Change History (2)

#1 @duck_
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #5809 just replace tags/categories with nav_menu and your custom taxonomy.

#2 @thomask
4 years ago

Agree, the problem with menu is even worse as it is not possible to modify/create nav_menu slug, so it is not possible to simply use same name with different slugs :-(
I hope they will faster sollution for this 4 years old (!!!) bug

Note: See TracTickets for help on using tickets.