WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#20708 closed defect (bug) (duplicate)

Wrong posts count in taxonomy table

Reported by: thomask Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.3.2
Component: General Keywords:
Focuses: Cc:

Description

when you are using same taxonomy for more post types, and you look at the taxonomy edit screen (/wp-admin/edit-tags.php?taxonomy=taxonomy-name&post_type=post-type) the table on the right shows wrong count - total of all taxonomies.
It is not exactly "problem", i understand why it is done, wp maintains only one count, but anyway it is a bug and may confuse someone, when he sees e.g. 5 items in the table, click on the count and there he would see only one item.
IMO there are two possibilities how to solve it
a) create counts "live" - not db efficient, but may not be a big problem, as the taxonomy edit screen is not opened too often
b) put the counts to the taxonomy->post_type pairs table

Change History (1)

comment:1 johnbillion2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closing as dupe of #14084 for the same reason as #14076.

Note: See TracTickets for help on using tickets.